x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.7 Can't find anything in this new BP editor

Ok. I just jumped into 4.7 I try not to update cuz All it ever does is slow me down...I must be stupid but something ALWAYS goes wrong. alt text When I open my Blueprint it looks like this and I've selected countless options in the tabs up above but cannot even understand why it looks like this. So again. Can anyone help me? or sure it's super simple....I just don't do well with updating....

Product Version: Not Selected
Tags:
empty.png (86.5 kB)
more ▼

asked Apr 02 '15 at 10:43 PM in Bug Reports

avatar image

AttemptD
1k 165 162 354

avatar image Sychris Apr 03 '15 at 01:06 AM

A bit odd for sure i don't normally see that toolbar tab on my BP's and there's usually something else there (my graph's tabs) so in your window menu under tool bar before content browser there should be something else there that is what you want in that main view port and toolbar should by checked and uncheckable, so try clicking on that. (nothing should happen but you never know) also if this doesn't help a bit more info that would greatly help. Is this all BP's, what version are you using, (a new update came out a few hours ago 4.7.4) what all options are in your window menu. you also seem to be missing the details window as well. have you used multi monitors in the past? (maybe there attempting to be off screen)

avatar image AttemptD Apr 03 '15 at 01:17 AM

Thank you for responding. It's only one BP as of now. A deer. In midst a forest. I'm using 4.7.3 bur I'm pretty sure it's only one BP. The Animation BP opens up fine and so do all other editors. If I open my windows tab I don't see ANY options to help get back to the screen. What happened was 4.7 is setup differently...so I got lost and exited out of re tabs and now they're gone.

avatar image Sychris Apr 03 '15 at 01:52 AM

ah ok i just closed all the tabs on a bp and was able to reproduce this. here is what I did to fix it,

window menu My Blueprint this will open something to give you access to the graph's, functions, macro's and variables listings.

you will than have to double click on either graph's functions macro's etc. to open up your BP graphs and return your "code" to a view able and manageable state.

avatar image AttemptD Apr 03 '15 at 02:06 AM

Thank you my friend. I'll try this immediately!

avatar image AttemptD Apr 03 '15 at 03:24 AM

![alt text][1]

I don't seem to have that option?? [1]: /storage/temp/37145-error.png

error.png (107.1 kB)
avatar image AttemptD Apr 03 '15 at 03:27 AM

I also just tried another BP deleted all the tabs but have all of the options in the window like usual...I may try to duplicate at this point but I'm not sure...something is wrong.

avatar image Sychris Apr 03 '15 at 03:47 AM

hmm.. ok so I agree there is something buggy about that menu there. I have had that menu miss some things before as well.. found this after some searching https://answers.unrealengine.com/questions/10858/bug-missing-menu-items.html as a side note what I generally do tot fix this is on a per BP issue is to pull that one BP in to its own window , save it, close all other tabs (except the main one) close offending BP and reopen it. I seam to ( Temporarily ) have all options. than try the above fix. sry this is messy... the fix in that post may be more permanent of a fix but I have not personally tried it.

avatar image AttemptD Apr 03 '15 at 04:00 AM

thank you for your help....it doesn't seem to be the exact same issue as it was from Beta 5, I'm gonna file this as a bug report, until then I'm updating to 4.7.4 as we speak and I'll see if this problem persist. Thanks again.

avatar image AttemptD Apr 03 '15 at 04:14 AM

Unfortunately As of 4.7.4 blueprints do not work at all. On any project ...even a Blank project. No matter the type of BP, once it is created, I can simply open it, click compile, close it, and after that all of my menus are gone. I'm not 100% sure what could be the problem there because I don't feel like that's an issue to many people...It's obviously in no way operable at this point.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

There is basically something in the BP that checks to see if it has any work in the graph. If not, it gets rid of all panels. In the window there is an option for BP class....There u can access everything again.

Thanks !

more ▼

answered Apr 06 '15 at 01:42 AM

avatar image

AttemptD
1k 165 162 354

avatar image Samantha Sutton ♦♦ STAFF Apr 06 '15 at 06:17 PM

Hey AttemptD,

I'm glad that you've been able to resolve this issue on your own. Would you mind providing me with detailed reproduction steps, so I can investigate this issue further and report it to our developers? Even an uploaded project where you've reproduced it yourself outside of your private project would be greatly appreciated. We've seen an increase in reports of this issue and would like to get it completely resolved.

Thank you! :)

avatar image AttemptD Apr 07 '15 at 01:30 AM

I'll have it up and detailed tomorrow. No problem!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

So I've figured out the source of the problem and it sucks. If I make a character class BP in my level, as soon s I assign an animation blueprint to it, after the BP is closed everything is gone once it's reopened. I tried this with another BP and another Anin BP and it still does it. I'm in 4.7.3

I'm not sure if anyone has had that problem but that's what's going on.

more ▼

answered Apr 03 '15 at 03:37 AM

avatar image

AttemptD
1k 165 162 354

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question