x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[LPV] Emissive lighting fails

Emissive lighting fails to render on the ambient environment when configured to do so following these instructions in the documentation.

I'm trying to simulate an LED array - thus far I've setup my material in a way that seems to work as I would like it to look with parameters for the color and intensity: material

Then I can put it into a blueprint to setup the color and intensity: blueprint

And it appears to get the fog within the blueprint preview, but without illuminating the object under it: preview

When displayed it does not manage to display any form of illumination, just the color of the plane (it's a 1-sided plane so you can only see a bit of the shading from this angle): rendered

I tried following the instructions here to illuminate the objects in the world around the plane by setting it's Mobility to Static and the Use Emissive for Static Lighting to true then rebuilt the lighting, however the result is the same as it was previously.

The effect I'm trying to accomplish is like the lighting from this video: ideal effect

What is the best way to go about this? Do I need to create a bunch of different point light sources for each lighting panel? How do I get the fog to show if I do have to fudge the lighting with point lights instead of using the object's emissive properties to illuminate the objects around them?

Edit: I've tried point lights (can't use non-static ones without it failing to build them and need stationary in order to have adjustable lighting) and that wasn't a solution. There is no volumetric fog so that isn't a solution. I have changed this to a bug report as it is something included in the documentation that doesn't appear to work.

Product Version: Not Selected
Tags:
untitled.png (275.7 kB)
untitled2.png (100.8 kB)
untitled3.png (236.2 kB)
untitled4.png (210.6 kB)
untitled5.png (1.6 MB)
more ▼

asked Apr 05 '15 at 02:19 PM in Rendering

avatar image

CoryG
123 13 20 30

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi CoryG -

Using Emissive for Static Lighting will only work for baked lighting and cannot be changed at runtime. You will need to have Precomputed Lighting turned on and you will need to build lighting for this function to work.

You can enable Light Propagation Volumes in your Project by adding the 'r.LightPropagationVolume=1' into the Engine's Console Variables INI file found in the Engine's Config Sub Folder. After doing that you can then check Emissive (Dynamic Area Light) to true in the Material. This will allow you to change the emissive color and have the color of the emitted light change as well.

In the Blue Array image above, the "fog" you are seeing is more probably Bloom and can be increased or decreased in the Post Process settings.

Thank You

Eric Ketchum

more ▼

answered Apr 06 '15 at 08:56 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 735

avatar image CoryG Apr 06 '15 at 09:33 PM

I've inserted the config line into the .ini file, checked the Emissive (Dynamic Area Light) flag on the material and applied it to a mesh, set the Use Emissive for Static Lighting parameter on the mesh within the blueprint, set it's color/intensity parameters within a function called by the construction script and inserted the blueprint into a level - however there is no noticeable effect. This is a screenshot after the lighting has been freshly rebuilt (the thin blue line is the new mesh that should be emissive - it faces down and is the same size as the blue panel above it): alt text

untitled.png (584.7 kB)
avatar image Tim Hobson ♦♦ STAFF Apr 07 '15 at 07:03 PM

Hi Cory,

Enabling "Use Emissive For Static Lighting" won't do very much if you're using dynamic lighting. This is meant only for static lighting builds using lightmaps.

In order to use Emissive lighting from an object with your via a material you need to have a Directional Light in your scene that is has the flag for "Dynamic Indirect Lighting" enabled. This flag will enable LPV to be utilized.

The emissive material works by injecting the color into the light propagation volume that is generated from the directional light. The emissive material will not create light by itself.

Here is the results with a base emissive material in an LPV scene that has not enabled the flag "Emissive (Dynamic Area Light)" in its material.

Disabled: alt text

Enabled: alt text

It should also be noted that LPV is only supported for the Directional Light at the moment. It does not support SPOT or POINT lights. There is a feature request in for this with ticket UE-3138.

LPV is currently not in a "Production-Ready" state and some things are expected to not function properly at this stage. There are some changes that will hopefully be implemented from Lionhead Studios (studio that made LPV) for 4.8, but there are no promises on that one.

I hope this helps.

Tim

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question