Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Source control login Perforce doesn't works


Yesterday, I installed P4admin and p4V (perforce). My goal was to log in through the Source control login from UE4 to my local Perforce Server. But the issue i'm encountering is that I get this error each time : " Error Failed to connect to source control. Check your settings and connection then try again. " Or "Error Workspace 'MyProject' does not map into this project's directory."

alt text

By the way, my perforce server works great, I can log in without any issues from p4v. So, then, I tried to log in from Visual Studio to my Perforce Server with Source Control Login... And guess what, it works... =_= (The informations filled are the same as UE4 Source control login) :

alt text

To resume, when I fill the Workspace field on UE Source Control, I get this error: "Error Workspace 'MyProject' does not map into this project's directory." When I don't, I get this one : " Error Failed to connect to source control. Check your settings and connection then try again. " And I never see any available workspaces from the select list. Meanwhile, I can log in from Visual studio.

I'm loosing hope, I'm tired and I don't understand why it doesn't work, I'm trying to fix it since yesterday. Is something wrong with my UE4 version maybe (4.7.4)?

Oh, thank you for reading and for your replies :)

Have a good day.

Best regards.

Product Version: Not Selected
more ▼

asked Apr 05 '15 at 07:29 PM in Using UE4

avatar image

6 1 1 2

avatar image Ryanesaurus Jan 23 '19 at 11:37 PM

God I’m so sick of NOTHING WORKING. Can’t find a single answer to a single issue relating to UE4!!!!!! All I wanted to do was work on the same project on two different computers. I have wasted the past two fkn hours doing this. Finally downloaded perforce and the sht doesn’t work. CAN I GET A BREAK?!!!!!!!!

avatar image ThompsonN13 Jan 24 '19 at 01:08 AM

how about posting your own question so you can get help with it directly. that would be the best way to get help with your exact issue. your basically just necroing old posts and complaining so you cant really expect too much help.

avatar image Ryanesaurus Jan 24 '19 at 01:21 AM

Because nothing will work :) so what’s the point of asking a question whenill never get it resolved. So I’m just going to vent, because everything is either A) Broken, B) Unrelated to my problem, or C) Going to be explained using heirogliphs and code that I won’t understand. And if I did understand it, it still wouldn’t be the fix!!!! This is just my luck with technical issues like these. There is NO fix

avatar image Chyros Jan 24 '19 at 02:20 AM

Still, asking a question with details (errors you read, things you performed, etc...) will help people better understand your real problem that can help them help you solve your problem.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first


  *"Error Workspace 'MyProject' does not map into this project's directory."* 

This is because your UE4 project files and your perforce workspace must be the same directory!

For example: If your workspace is at: C:/UE4Projects/MyGame/

Then your .uproject file must be at C:/UE4Projects/MyGame/MyGame.uproject

And you have to use this .uproject file and connect to this workspace.

 Error Failed to connect to source control. Check your settings and connection then try again

This one is most likely caused by an offline perforce server.

You can install the perforce server on your local machine but your mates will not be able to submit / checkout etc.. if your machine is offline or the perforce server is offline.

There is a free perforce hosting: https://www.assembla.com/repositories/perforce

more ▼

answered Apr 05 '15 at 08:56 PM

avatar image

1.9k 60 50 189

avatar image Mr.NiceKai Nov 10 '16 at 10:45 PM

Thank you.

I opened a map, made with 4.12 and prgram asked to update to new version. I can't connect with the source. So I tried and restarted - and.... can't remember why... checked my project folder again. Now I see - 2 folder ProjectName and ProjectName 4.13 That is the solution, because perforce is connected with ProjectFolder. After I changed, everything was correct.

Thanks for the solution ;)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Sorry to revive an old thread, but I got the same exact issue and in my case it's intentional. Since I don't have enough space to have my whole workspace (containing multiple projects), I put one of the project in a symlink directory. My workspace is in a directory inside C: but the project is actually in a directory in the D: drive. This causes a bug inside unreal like Azarus said where UE4 project files and the perforce workspace aren't in the same directory.

I've searched everywhere for a solution and at the moment the only thing I could do is create a new workspace...but it's really not ideal. As we are setup right now, each person has only one workspace and we want to keep it that way (we have a max workspace amount available).

Is there any other solution ? Thanks

more ▼

answered Oct 17 '18 at 03:00 PM

avatar image

1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question