x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Endless Runner Tutorial in Unreal 4.7 keeps crashing on infinite loop.

Hi, I'm learning the engine through the tutorials, i've done a couple of them, however, in the endless runner tutorial, from the point where I make the child Blueprint of the floor tile and access it through a Floor Tiles Array, once the Pawn crosses the first Trigger Collider, the game crashes and reports an infinite loop.

I've double checked every step of it, the tiles seem to be working when i simulate the game, it's when the runner Pawn triggers the Add floor Tile Function that the Bug happens and crashes the game. And Also, only when the FloorTilesArray is being used in place of the single Floor_BP.

Another thing I've noticed is that when I compile the FloorTile the RunGameMode BP gets decompiled, and vice-versa. Also when it crashes it says

Script call stack:

"Function /Game/ThirdPersonBP/Blueprints/PickUp.PickUp_C:BndEvt_PickupItem_K2Node_ComponentBoundEvent_127_ComponentBeginOverlapSignature_DelegateSignature Function /Game/ThirdPersonBP/Blueprints/PickUp.PickUp_C:ExecuteUbergraph_PickUp"

Here my blueprints so far:

Is it something i've done or...?

[1]: /storage/temp/37516-floortilebp.jpg

Product Version: Not Selected
Tags:
more ▼

asked Apr 05 '15 at 10:46 PM in Blueprint Scripting

avatar image

Efe3d
1 1 1 2

avatar image MarcusH Jun 07 '15 at 12:05 PM

Hej, I have the samme problem. My tile also decompiles as soon as i compile the game mode and vice versa. If i choose the default game mode, it doesn't crash but if i use the game mode that spawns the world, it allways crashes and says that something, like a construction node, is causing an infinte loop. Would be nice to figure out what causes this.

avatar image Narghile Jun 07 '15 at 01:57 PM

Hi

What version you using, you have not stated?

I use this in 4.7.

Narg

avatar image MarcusH Jun 07 '15 at 02:00 PM

Im also using 4.7

avatar image Narghile Jun 07 '15 at 02:11 PM

Ok,

Works fine in 4.7, which loop is this happening?

Narg

avatar image MarcusH Jun 07 '15 at 02:16 PM

It switches. For example, if i play, it crashes and says that the call stack is creating an infinite loop due to the construction script in my "Tile_1". But if i delete the construction node, it just complains about somthing else, like an destroy actor node or begin actor overlap node. Funny thing is, it all worked fine until i made two instances from one pickup item i had in the scene. Now, no matter what i do, it just crashes and gives me that error. Have tried deleting the original pickup and all the instances, but it doesn't make a difference

avatar image Narghile Jun 07 '15 at 03:25 PM

Hi Mate

If error says construction script, does not mean construction script.

I had a Error - Infinite Loop, but was in Graph, so do not always believe error message.

But a Break in until you find error.

Narg

.

avatar image MarcusH Jun 07 '15 at 03:30 PM

Hey Narg Thanks for the reply. I know it's not necessarily the node it specifies, that is the problem, i tried deleting every node it complained about and it still complained about nodes that werent even connected nor active. It just kept crashing. But maybe i should try again, just delete every event/ function node i can find, to see if it says something else.

avatar image Narghile Jun 07 '15 at 03:50 PM

I may get a chance to later to look.

See if I can see something that would cause it.

Narg

avatar image MarcusH Jun 07 '15 at 04:40 PM

Cool, thanks

avatar image Narghile Jun 07 '15 at 07:28 PM

hi

Might seem stupid, but have you gone through the tutorial again?

at a glance, looks right.

check your code

You have not posted all of your code, example, where is "add tile", "Spawn coin" & "spawn blockers" functions, ,ight be there?

Narg

avatar image MarcusH Jun 08 '15 at 02:35 PM

Hey again, This post isnt mine, i just commented on it. It seems that i have gottne more or less to work again, although i have no idea how. I basically just picked most of it appart and assembled it again, with new names. But it seemes like small errors occur, like my death event disapearing. Ill post all my stuff if it happens again. And thanks.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question