x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

PlayerState is null on clients

HI!

i have some issue with PlayerState object replication in multiplayer. For example, i've created ThirdPersonExample and in level blueprint i put this nodes to test: alt text I hit play in editor with 2 clients and dedicated server checked. log shows me this:

Client 1: Null

Client 1: Valid

Client 1: Valid

Client 2: Null

Client 2: Valid

Client 2: Null

etc.

So, is that normal? I think after PlayerState replicates from server to clients, it shouldn't be null?

Product Version: Not Selected
Tags:
more ▼

asked Apr 06 '15 at 09:53 AM in Blueprint Scripting

avatar image

AndrewFord
94 2 14 14

avatar image Rudy Q ♦♦ STAFF Apr 06 '15 at 05:57 PM

Hello AndrewFord,

I was unable to reproduce this issue on a dedicated server. However, I used pawn inside of my get all actors of class. This appears to have worked for me. If you change yours to use pawn do you still get the same result? If so, I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. What version of the engine are you using?

  2. Can you reproduce this issue in a clean project?

  3. If so, could you provide a detailed list of steps to reproduce this issue on our end?

avatar image AndrewFord Apr 06 '15 at 08:48 PM
  1. i'm using 4.7.4, downloaded through launcher

  2. i was doing my test on a clean project (ThirdPersonExample, Blueprint version)

  3. Sure

i've just created a clean project. Then, i opened level blueprint alt text alt text alt text

avatar image Rudy Q ♦♦ STAFF Apr 08 '15 at 08:58 PM

Hello AndrewFord,

Thank you for providing the information, however after following the steps provided I have still not been able to reproduce this issue on our end. I do have another question for you. Can you replace your "foreachloop" node with a new one? The data will sometimes not update.

avatar image AndrewFord Apr 11 '15 at 11:57 AM

I captured the video of this issue. YouTube Doubt it should work like this...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello AndrewFord,

After watching the video I noticed that the default character for the third person template was still in your level. I know this because you have 3 characters in your level (but only two players). This means when you play this project as a dedicated server there are no players left to possess this character. If you delete the default character out of your level this should solve your issue. I hope that this information helps.

Make it a great day

more ▼

answered Apr 13 '15 at 03:46 PM

avatar image

Rudy Q ♦♦ STAFF
47.3k 545 132 525

avatar image AndrewFord Apr 13 '15 at 06:09 PM

Hi, Rudy!

Yeah, removing the character helps. Thanks for the answer!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question