x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Instanced Static Meshes in Blueprints collision translates incorrectly.

If you create a blueprint with an instanced static mesh. Spawn it in the world. And then translate it after it has spawned, it's collision will not have moved even though the visible mesh will have moved.

I first produced this using the Top Down Sci Fi Asset Set. I can reproduce this in a new project.

This is causing issues for us as our map generation system relies on moving blueprint tiles after it has spawned.

Product Version: Not Selected
Tags:
more ▼

asked Apr 06 '15 at 09:54 PM in Bug Reports

avatar image

Deepfried
33 2 4 7

avatar image Adam Davis STAFF Apr 08 '15 at 03:17 PM

HI Deepfried,

Can you show me your blueprint setup?

avatar image Deepfried Apr 08 '15 at 07:15 PM

I used the third person blueprint default. I imported the top down sci fi asset bundle. Deleted all the obstacles and floor and moved the player start to just above the origin: http://i.imgur.com/DgMan6c.png

Created this blueprint: http://i.imgur.com/TgmB7q6.png

And then put this in the level blueprint: http://i.imgur.com/3h68sOC.png

And then when I run I get this: https://youtu.be/FEVdCMHW1P8

avatar image Adam Davis STAFF Apr 08 '15 at 09:15 PM

Does this only occur with the sci fi assets or is it any asset that you utilize?

avatar image Deepfried Apr 08 '15 at 10:31 PM

I made a new 3rd person with the starter content and used the Shape_Cube. The same effect happened. I also noticed another bug: If I set the instancedStaticMesh scale under A here: http://i.imgur.com/wjQvJYT.png Then it changes the scale in the blueprint viewport, however when you run the scale has not been changed. You have to set the scale on each individual instance in the array (B).

avatar image Adam Davis STAFF Apr 09 '15 at 03:45 PM

Are your meshes set to static or movable?

avatar image Deepfried Apr 09 '15 at 04:13 PM

As in the picture they are set to movable.

avatar image Adam Davis STAFF Apr 09 '15 at 07:54 PM

Do you see the same results if you set the object with your make transform?

avatar image Deepfried Apr 09 '15 at 08:41 PM

If you mean if I set the initial spawn location, it can spawn anywhere correctly, its any translation after spawning (using set actor location, or set actor transform) that causes it to disconnect display from collision.

Even moving it in editor causes it to move without its collision.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Still not working in the new 4.12 update :(

more ▼

answered Jun 02 '16 at 07:14 AM

avatar image

Morguhl
36 5 5 6

avatar image Morguhl Jun 02 '16 at 12:32 PM

I solved my problem today! The problem was that i did not use "Complex Collision as Simple" for the original Static Mesh and i did all the collision settings in the Blueprint Actor of the Door.

What i did now was to setup everything in the original static mesh of the door and used the Default Settings in the Blueprint actor. That solved the issue for me!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Deepfried,

I was able to reproduce this and have entered a bug report, UE-13673 to be assessed by the development staff.

more ▼

answered Apr 10 '15 at 05:23 PM

avatar image HuntaKiller May 06 '15 at 09:04 AM

that's the second bug that's a big thorn in my side. Really hope they're addressed next patch :)

avatar image Robert Gresdal Jul 18 '15 at 06:31 PM

Wish I had searched for this a bit more before spending 10 hours on this :-|

Going to watch that bug report, it's make or break for my project.

avatar image wilberolive Dec 22 '15 at 08:12 PM

Did this get fixed yet?

avatar image Adam Davis STAFF Dec 22 '15 at 08:17 PM

Hi wilberolive,

Unfortunately this report is still under assessment. I do not have a timeframe of when a fix will be implemented.

avatar image John Alcatraz Feb 22 '16 at 09:19 PM

Oh, please fix this! I need this in 4.11.

avatar image John Alcatraz Feb 22 '16 at 09:21 PM

Does anyone here have something like a workaround to make the ISMC update the collision correctly?

avatar image HuntaKiller Feb 22 '16 at 09:38 PM

yes, you put the mesh where it needs to be, then delete it and create a new mesh at that location without translating it

avatar image Aigal Studio Mar 30 '16 at 03:37 PM

Hi! Do you have any news?

avatar image Adam Davis STAFF Mar 30 '16 at 06:26 PM

Hi enchorage,

This bug is still under assessment by the development staff. I do not have a timeframe of when a fix will be implemented.

avatar image Aigal Studio Apr 10 '16 at 04:40 PM

Ok thanks!

avatar image HuntaKiller Jan 20 '16 at 07:02 AM

Priority upgrade please

avatar image Jamendxman3 Feb 22 '16 at 11:45 PM

Looks like there are no real workarounds, as all of them demolish performance. I'd like to bump up the interest in this.

avatar image Ypsylon May 24 '16 at 12:39 PM

Hi guys, i have found workaround somewhere on forums, u can disable component collision before moving it and enable collisions right after. It works like a charm and do not cause any significant performance issues

EDIT: i am using small amount of instances right now so it may not be usable for all use cases ;)

avatar image Morguhl May 31 '16 at 03:50 PM

The workaround doesnt seem to work for me. This seriously is a crazy bug to still be in after such a long time! For me it happens when opening a door. Wasted two days trying to get a workaround now. Guess i will start working on other parts of this project and hope it gets resolved soon...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question