x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Array 3D widget positions

4.7.4

  • Make an array of vectors

  • Set "Show 3D Widget" to true

  • Drop BP into map ( because you can't click and drag widgets in BP, which is another bug )

  • Manually set values for a few different points

  • Compile and save

  • Delete the temporary instance in the map

  • Drop a new instance in with the modified defaults

  • Widgets are displayed in incorrect locations in BP ( they still work fine for application )

Black background is in the map editor with correct positions.

Grey background is in the BP editor with incorrect positions.

bp editor

map editor

Product Version: Not Selected
Tags:
widget_map.png (57.6 kB)
widget_bp.png (22.9 kB)
more ▼

asked Apr 07 '15 at 01:32 AM in Bug Reports

avatar image

Neros_
279 29 42 54

avatar image Neros_ Apr 07 '15 at 03:32 AM

Looks like they show up in other blueprints that don't even have that vector array. other bp

widget_otherbp.png (35.3 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Taisaku,

Thank you for the report. I created JIRA report UE-13384 for the issue where the widgets are different in the blueprint viewport vs when placed in the level. Our developers will be investigating the issue further and we will post here with updates as we have them.

I also entered a Feature Request for the ability to translate the widgets inside of the blueprint instead of having to set them manually.

Cheers,

TJ

more ▼

answered Apr 07 '15 at 07:22 PM

avatar image

TJ V ♦♦ STAFF
41.1k 1009 183 493

avatar image bennetherwood Sep 05 '15 at 06:55 PM

was this fixed ? It is also/still present in 4.9

avatar image Neros_ Sep 05 '15 at 06:59 PM

I'm not sure, i had to change the way I did my path, im using scene components instead of a vector array (probably less efficient, but it works)

avatar image TJ V ♦♦ STAFF Sep 08 '15 at 04:28 PM

Hey guys,

This is still not fixed but it is being investigated and has moved up in priority.

avatar image Cavechild Mar 09 '17 at 10:25 AM

This is still present in 4.14, I have an array of FVectors in my component and cannot see any editor widgets for them in the blueprint viewport. Has any progress been made on this since 2015?

avatar image TJ V ♦♦ STAFF Mar 14 '17 at 04:47 PM

Hi Cavechild,

This is still an open JIRA in our system. I updated my original answer to include the link to the public JIRA version. Please feel free to vote on it.

This was also reconfirmed as an issue in our latest internal build and our devs were made aware.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question