x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Editor crash and memory leak

Most of them time I use code but lately I started to do things with blueprint. And sometimes editor just crashes without good reason. Also I noticed that editor eats more and more memory in time. Just now it crashed when I tried to drag and drop local widget variable to the outpu of create widget. And after restart it crashed again. This is screenshot of crash: alt text Here is the crashlog:

crashlog

Each time I receive the same crashlog. I even deleted everything from this widget except of this function (Arguments were deleted also) and this create widget and variable. And again, after I drag and drop it crashes. I checked, now this widget doesn't even have any external references. So that's why I decided to not just drag and drop but firstly to create this set node. And then connect it to output of create widget. Now it works. And after that I decided to make another test. I deleted this set node and drag and dropped variable again. It crashed. So now I have this uasset which doesn't depend on any other assets. So I made blank project. Imported just this asset. Drag and droped that variable. Crash. I renamed asset to .txt and attached it. So if you can, you can study it closely (don't know if it is possible)

asset file

Also here are some memory logs I made yesterday. I had again a lot of memory consument (1.8GB for a simple project). And after restart there were only 1GB:

1.8GB

1GB

I renamed them from memreport to txt. I made them with memreport -full.

Product Version: Not Selected
Tags:
crash.png (97.3 kB)
crashlog.txt (3.9 kB)
lotsofmemory.txt (116.4 kB)
afterrestart.txt (100.8 kB)
more ▼

asked Apr 08 '15 at 09:45 AM in Bug Reports

avatar image

funbiscuit
69 9 14 17

avatar image funbiscuit Apr 08 '15 at 03:06 PM

I noticed last hour or more my computer was very laggy. I looked into task manager and now editor has eaten 4GB of RAM. That's a lot for me. Here is memreport which I got with memreport -full

[4GB][1]

It was in the same project. Project is just a third person template with a little bit of my blueprints. [1]: /storage/temp/37977-4gb.memreport.txt

4gb.memreport.txt (118.9 kB)
avatar image Adam Davis STAFF Apr 08 '15 at 05:44 PM

Hi funbiscuit,

If you go to the filepath \Unreal Projects\PROJECTNAME\saved\logs\, can you upload the .dmp and the logs located there to here? Additionally, can you post your dxdiag?

avatar image funbiscuit Apr 08 '15 at 05:49 PM

I added everything what was in that folder to zip file. dxdiag is also there logs

logs.zip (99.7 kB)
avatar image Adam Davis STAFF Apr 08 '15 at 06:06 PM

Have you changed any of the folder structure for your project? Renamed any folders or moved assets around to new locations? Additionally, is the memory leak occurring while the editor is open or does it occur after the crash?

avatar image funbiscuit Apr 08 '15 at 06:10 PM

I don't think I changed structure of the project when I got crash for the first time. Later, as I said I copied this widget to empty project without all other assets. I have this leak almost all the time. I just don't notice it sometimes. Maybe it doesn't crash because of leak. It just gets very laggy. For example now I opened task manager and editor eats 2GB. Project is the same.

avatar image Adam Davis STAFF Apr 09 '15 at 03:23 PM

Can you send me a copy of the asset that is causing this error? I will be happy to test on my end and see if I get the same results.

avatar image funbiscuit Apr 09 '15 at 03:58 PM

I attached it to the first message (asset file) i renamed it ro txt to be able to attach. Just rename it back to uasset (it is called questnodewidget.uasset.txt)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi funbiscuit,

I was able to reproduce this crash and have entered a bug report, UE-13595 to be assessed by the development staff.

more ▼

answered Apr 09 '15 at 06:57 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This crash was fixed in this github commit. Thank you so much for your detailed bug report. This fix will be in the 4.8 binary release.

more ▼

answered Apr 13 '15 at 09:44 PM

avatar image

Dan.OConnor STAFF
495 14 7 17

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question