x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Importing one .fbx creates 20 static animations

So I made a simple idle gun animation in Blender. I exported it as an .fbx and then attempted to import it into Unreal. Once imported, it creates a physics asset, a skeleton, a skeletal mesh, AND 20 animations! My Blender file had multiple objects, so I tried merging all the objects one, and re-exporting/re-importing. It changed the animation count to 12.

When I look at the individual animations, they are completely static - no movement. I only have 3 keyframes in my Blender animation. Each animation takes the form of one of the keyframes. There are no animations showing the parts between the keyframes.

How do I fix this so when I import my .fbx, I get a single animated animation?


I should also note that when I imported my .fbx, I got several warnings:

  • "The following bones are missing from the bind pose:" Followed by the last bone in each of my fingers with _end appended to the end

  • A whole bunch of "Missing influence on vert X. Weighing it to root." I assume this is referring to the vertices in my gun, as I didn't want the bones in the hands to interfere with the gun

  • A couple "Imported bone transform is different from original." errors


For reference, here is a picture of my animation in Blender:

My Blender .fbx export settings:

And my Unreal import settings:

Product Version: Not Selected
Tags:
mesh.png (14.0 kB)
fbx export.png (35.7 kB)
more ▼

asked Apr 08 '15 at 11:25 PM in Using UE4

avatar image

Chuckleluck
18 5 7 9

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I'm not sure if this is your problem or not but I think I've experienced some similar things when importing stuff made in blender into UE4. What you need to do is, in Blender, open the dope sheet then the action editor. Once there, delete any actions that you are not using or have no actual animations in them.

About the problems with the verts in the gun. If you want to have the gun be a part of the same skeletal mesh you will need to weight it to something or it will be done for you. What I would do is put a single bone in the gun then weight the gun entire gun to it.

Also, from my experience, its best to check the "Only deform bones" box in blender, and I've gotten a lot of horrible animation errors when using the 7.4 fbx format with skeletal meshes exported from Blender. I use 7.4 for my static meshes but only the 6.1 for all my skeletal.

Hope this helps.

more ▼

answered Apr 15 '15 at 04:42 AM

avatar image

masterwigglestin
61 13 16 18

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question