x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't input after opening from another level?

I have just encountered this problem, which I have never gotten before when using this exact method.

When I open a level from a UMG widget I cannot input anything, not in the level, and not the editor controls either, (ie. escape to stop play in editor)?

alt text

alt text

It isn't a problem with the level, as if I open the level in editor everything works fine?

PS. I have tried setting input mode on begin play in the level to be opened, but as I expected it didn't do anything, as I didn't think it should.

Product Version: Not Selected
Tags:
more ▼

asked Apr 09 '15 at 02:48 PM in Bug Reports

avatar image

Oscar Cooke-Abbott
542 54 59 73

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello WarLord,

I was able to reproduce the issue that you mentioned above. However, I do not believe that any of the nodes are working outside of their intended functions. The set input UI only node is what is causing you to lose input capabilities (intended). The node usually sets a target for what UI you would like to have sole control over input. You are then removing the only item in your game that can except input. You could try setting the input back to Game and UI just before changing levels. I believe this will allow you normal input capabilities upon switching levels. I hope that this information helps.

Make it a great day

more ▼

answered Apr 09 '15 at 05:33 PM

avatar image

Rudy Q ♦♦ STAFF
47.2k 545 132 525

avatar image Oscar Cooke-Abbott Apr 10 '15 at 08:27 AM

Yes, that solved the problem completely!

Thankyou very much for your time :D

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question