x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Application breaks off when Movie is running [4.7.4 and 4.7.5]

Hi, I have a problem with intro movies for mobile devices (Actually in Android only. Not tested on IOS).

alt text

When I use a MP4 movie as an intro movie and the movie ends up, I see the main menu from the game, but the application freezes and closes/crashes.

alt text

But removing the movie from project settings game works.

Tested on the following Android devices:

huawei P7-L10 - android v4.4.2

miTab BALTIMORE - android v4.4.2

jiayu g3s turbo - android 4.1.2

Product Version: Not Selected
Tags:
movie asset.png (23.0 kB)
movie settings.png (17.4 kB)
more ▼

asked Apr 10 '15 at 03:20 PM in Bug Reports

avatar image

Helghast
102 11 15 69

avatar image wittlief ♦♦ STAFF Apr 10 '15 at 07:23 PM

Hi Helghast,

Can you attach to this thread the output logs of your apk's successful build, and the logcat logs from the crash?

Thanks very much!

avatar image Helghast Apr 11 '15 at 11:03 AM

I attached logs. Some lines are in Spanish. Apologies.

link text

ue4 logs.zip (351.7 kB)
avatar image wittlief ♦♦ STAFF Apr 13 '15 at 03:57 PM

Hi Helghast,

Are you using binary or source version of the editor? Also, in the logcat I'm seeing what looks like SDK setup errors, do you mind taking a screenshot of your SDK settings and posting here? Are you using a recent version of TADP or the one that comes with the editor?

I'm seeing several errors in your log that indicate you might be using assets that are unsupported for mobile development in UE4. Can you have a look at this documentation for General Mobile Development and see if there's anything you're using that might be causing a crash?

Thanks so much for including all those logs, btw, that's really a huge help.

avatar image Helghast Apr 13 '15 at 07:48 PM

-I'm using binary version.

-UE4 android SKD paths&config:

alt text

-I'm using Tegra Android Development Pack Release (4.0r1).

-Referenced to the unsupported assets, game is playable, except when I add the movie.

sdk config.png (23.9 kB)
avatar image wittlief ♦♦ STAFF Apr 13 '15 at 07:00 PM

Hi Helghast,

Did your project crash on all three devices that you listed? Were you able to get it to work on any device? Do you have any other devices on which to test? It's looking a bit like a memory issue for those devices, so any other testing you can do would be helpful.

Thanks!

avatar image Helghast Apr 13 '15 at 07:50 PM

Yep, crash on all three devices only when I add a movie.

I'll try on an iPad/iPhone.

avatar image wittlief ♦♦ STAFF Apr 15 '15 at 07:27 PM

Hi Helghast,

Were you able to reproduce the crash on an iOS device? Also is the mp4 located in your Project/Content/Movies folder? Here is a forums thread with some further info about video on Android.

Hope this helps!

avatar image Helghast Apr 17 '15 at 05:07 PM

I've noticed that sometimes works if I disable the "Google Play Services" (android). sometimes...

Yes, mp4 are in my Project/Content/Movies folder.

avatar image wittlief ♦♦ STAFF Apr 23 '15 at 05:24 PM

Hi Helghast,

Sorry for the reply gap. Does the disabling of Google Play Services only work intermittently, or does that solve your issue every time? If yes, then I can dig into that being the cause. If no, then it seems to indicate something else is the cause of your crash. If you can get a crash when you've disabled Play Services, can you include logcat logs here?

avatar image Helghast Apr 28 '15 at 08:43 AM

Well, I've created two APKs on Development mode, both with Startup movie:

-APK1: GooglePlay services = false

-APK2: GooglePlay services = true

After I used "adb logcat -s UE4" on my device, and these are the logs: On both APKs, aplication crashes after movie ends up. In the second, there are lines:

     D/UE4     ( 4250): [2015.04.28-08.40.17:197][  0]LogOnline:Display: OnlineSubsystemGooglePlayModule::StartupModule()
     D/UE4     ( 4250): [2015.04.28-08.40.17:197][  0]LogOnline:Warning: FOnlineSubsystemGooglePlayModule was disabled
     D/UE4     ( 4250): [2015.04.28-08.40.17:197][  0]LogOnline: FOnlineSubsystemAndroid::Shutdown()
     D/UE4     ( 4250): [2015.04.28-08.40.17:198][  0]LogOnline:Warning: Unable to create OnlineSubsystem module GooglePlay
     D/UE4     ( 4250): [2015.04.28-08.40.17:198][  0]LogOnline:Warning: Unable to load default OnlineSubsystem module GooglePlay, using NULL interface
     D/UE4     ( 4250): [2015.04.28-08.40.17:199][  0]LogModuleManager:Warning: ModuleManager: Module 'OnlineSubsystemNull' not found - its StaticallyLinkedModuleInitializers function is null.

And then others such as:

     D/UE4     ( 4798): [2015.04.28-08.43.50:190][  0]LogOnline:Display: OnlineSubsystemGooglePlayModule::StartupModule()
     D/UE4     ( 4798): [2015.04.28-08.43.50:190][  0]LogOnline:Display: FOnlineIdentityAndroid::FOnlineIdentityAndroid()
     D/UE4     ( 4798): [2015.04.28-08.43.50:190][  0]LogOnline: GPG sign in started
     D/UE4     ( 4798): [2015.04.28-08.43.50:190][  0]LogOnline: FOnlineSubsystemGooglePlay::OnAuthActionFinished, Op: SIGN IN, Status: ERROR_NOT_AUTHORIZED
     D/UE4     ( 4798): [2015.04.28-08.43.50:191][  0]LogInit: Presizing for 0 objects not considered by GC, pre-allocating 0 bytes.
     D/UE4     ( 4798): [2015.04.28-08.43.50:191][  0]LogInit: Object subsystem initialized

[link text][1] [1]: /storage/temp/40517-logcats.zip

logcats.zip (18.8 kB)
(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Helghast,

Based on the information you and others have provided, we have determined that a garbage collection change in Android 4.0 is causing many problems, including this crash. JIRA issue UE-14317 has been entered for this garbage collection issue, and is at this time scheduled to be included in the 4.8 release. Note that this is not a guarantee as the release approaches some issues will be pushed back to the next release. However, I have spoken with the dev involved, and as this issue covers a spectrum of problem fixes, I feel confident it will be included. I will update this issue as more information is gathered.

Thanks very much!

more ▼

answered May 04 '15 at 08:40 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question