x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Exporting .apk

Every time I try to export any apk, I always get ERROR: cmd.exe failed with args /c "D:/.../apache-ant-1.9.4/bin/ant.bat" -quiet debug

O tried quite a couple of different apache-ant versions, but I always get this error, therefore, can't export any .apk in the current version of UE4 (4.7.4)

Any ideas on how to solve that?

Product Version: Not Selected
Tags:
more ▼

asked Apr 10 '15 at 03:38 PM in Bug Reports

avatar image

Otokomidori
11 1 3 4

avatar image wittlief ♦♦ STAFF Apr 10 '15 at 05:59 PM

Hi Otokomidori,

Firstly, can you attach your entire failed output log to this thread as a text file to this thread?

Without seeing your whole logs, I have a small suspicion you're having the same problem as this user who posted on the Android forums. Have a look and see if you have the same error in your logs, and that would be your issue.

Thanks!

avatar image Otokomidori Apr 15 '15 at 12:49 PM

Yes, indeed I can.

link text

log.txt (843.2 kB)
avatar image wittlief ♦♦ STAFF Apr 15 '15 at 07:42 PM

Great, thanks very much. Ok, I'm seeing several SDK errors in your log, and I think it's related to this:

ERROR: Exception in UnrealBuildTool: ERROR: cmd.exe failed with args /c "D:/Apps/apache-ant-1.9.4/bin/ant.bat" -quiet debug

Can you make sure you have the correct version of Apache Ant that we support installed for your SDK? It should be 1.8.2 at this point. Here is a forum post from another user that shows the correct SDK setup in project settings for Android.

Hope this helps!

avatar image Otokomidori Apr 15 '15 at 07:51 PM

Thanks for your reply.

I do also have what you call "the correct version", but It works out just the same way, so I tried multiple other versions, but no success. Here's the other log: link text

log2.txt (843.0 kB)
avatar image wittlief ♦♦ STAFF Apr 15 '15 at 08:37 PM

Thanks for the logs. And you have your project settings like the picture in the forum post? Feel free to attach a screenshot of your settings to this thread for verification. You may need to restart your machine now that you have set it back to 1.8.2 in order for the settings to take effect. Thanks!

avatar image Otokomidori Apr 16 '15 at 04:06 PM

Yes, sure. Here are my android SDK settings

alt text

jpgscreenshot.jpg (41.0 kB)
avatar image wittlief ♦♦ STAFF Apr 16 '15 at 04:15 PM

Thanks for that. Can you set your NDK level to android-19, restart and see if that helps?

avatar image Otokomidori Apr 16 '15 at 04:25 PM

MainFrameActions: Packaging (Android (All)): Program.Main: ERROR: ERROR: cmd.exe failed with args /c "D:/Apps/AndroidSDK2/apache-ant-1.8.2/bin/ant.bat" -quiet debug MainFrameActions: Packaging (Android (All)): ProcessManager.KillAll: Trying to kill 0 spawned processes. MainFrameActions: Packaging (Android (All)): Program.Main: AutomationTool exiting with ExitCode=1 MainFrameActions: Packaging (Android (All)): Domain_ProcessExit MainFrameActions: Packaging (Android (All)): ProcessManager.KillAll: Trying to kill 0 spawned processes. MainFrameActions: Packaging (Android (All)): copying UAT log files... MainFrameActions: Packaging (Android (All)): RunUAT.bat ERROR: AutomationTool was unable to run successfully. MainFrameActions: Packaging (Android (All)): BUILD FAILED

:(

avatar image Otokomidori Apr 16 '15 at 04:26 PM

Still the same :S

avatar image wittlief ♦♦ STAFF Apr 16 '15 at 05:04 PM

You're restarting your computer when you make the SDK changes, right?

Can you try to package the Tappy Chicken project for development and ETC1 and attach the full output logs to this thread as a txt file? Thanks!

avatar image Otokomidori Apr 16 '15 at 07:00 PM

I did restart the computer after, that's true. Here is the log of flappy bird: link text

lognew.txt (766.3 kB)
avatar image wittlief ♦♦ STAFF Apr 16 '15 at 07:23 PM

Excellent, thank you. I see that succeeded, but your other build is still failing? I still see what looks like SDK errors, though, do you have any other SDK setup that could be incomplete, like say, Gear VR?

avatar image Otokomidori Apr 16 '15 at 07:30 PM

Correct. My personal project still fails to export. Only full SDK that I have is the one that came with unreal itself. Besides that, I have a newest version of apache ant, which, unexpectedly, looks like isn't compatible with unreal. So I plugged the original one back in. No gear VR in any way.

avatar image wittlief ♦♦ STAFF Apr 20 '15 at 06:28 PM

Ok, I should have asked this before, but are you running source or binary?

avatar image Otokomidori Apr 23 '15 at 10:33 AM

Well, I'm really sorry, but I'd be glad if you told me how to figure that out... That's what you get when you make designers be able to be a programmer also. :/

avatar image wittlief ♦♦ STAFF Apr 23 '15 at 05:22 PM

Binary is the editor version you get from the launcher, and source is the version you get from Github that requires compiling with Visual Studio. From your answer I am assuming binary, yes? :D

avatar image Otokomidori Apr 23 '15 at 07:18 PM

I suppose that's true :D

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

This actually looks like more of the same problem. Have you placed your .keystore file? Here is your error:

ERROR: Exception in UnrealBuildTool: ERROR: DistributionSigning settings are not all set. Check the DistributionSettings section in the Android tab of Project Settings

And here is another forums thread where a user was having the same error, and how it was fixed. Good luck!

more ▼

answered Apr 27 '15 at 06:08 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Otokomidori,

I've found the error in your personal project logs that is the cause:

D:\Apps\AndroidSDK2\android-sdk-windows\tools\ant\build.xml:542: Application package 'Otokomidori Productions' must have a minimum of 2 segments.

Luckily, this exact issue was addressed this week on the Android forums, with an explanation of how to fix it. Somewhat less luckily, if you end up seeing the same error as that user:

ERROR: Can't make an APK without the compiled .so [F:\Unreal Projects\Vehicle Game\VehicleGame\Binaries\Android\VehicleGame-armv7-es2.so]

You will be obliged to go into Visual Studio and compile. Chris Babcock mentioned in that thread the settings for that compiling, and here is the documentation that will walk you through compiling your project.

Good luck!

more ▼

answered Apr 24 '15 at 03:12 PM

avatar image Otokomidori Apr 24 '15 at 04:47 PM

I really appreciate your answer and work looking for it. Basic export works fine now. But there is one problem lol xD... Destribution build doesn't work :D link text

lognewagain.txt (847.8 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question