x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Skeletal Animation mesh disappears

Hi, I made a rigged character with a skeletal animaton in Blender 2.7.4, and when I import it into Unreal Engine 4, the mesh disappears when I try to play the animation, either as a preview in Persona or in-game.

I'm using Unreal version 4.7.5 from the Epic launcher, and importing the mesh as an FBX.

The animation seems to import, since it displays the proper length of the animation in Persona.

I have concluded that this is not an issue with Blender, since I am able to re-import the FBX file into blender and the animation works properly.

Product Version: Not Selected
Tags:
more ▼

asked Apr 11 '15 at 03:01 AM in Using UE4

avatar image

Henelik
3 2 3 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Took me the whole morning but I solved this problem. It's an issue with the FBX exporter in Blender. Essentially, when you export with scale 100 as you should it scales everything except for individual bones which retain a scale of 1.0.

Tried multiple solution but none worked. The only solution I found is to scale on import. When importing an animation (I import them individually) inside UE4 down in the transform option set the scale to 100 and it should work fin.

more ▼

answered Apr 30 '15 at 10:23 AM

avatar image

vernocchi
88 3 7 13

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I had a similar problem. Make sure your animation is baked (Edit>Keys>Bake Simulation on all joints) and then delete all NURBS curves and IK handles before exporting as an fbx file.

EDIT: By mistake I gave you the solution for Maya, which is what I used. Still, I'm sure there is an alternative way to solve this using Blender.

more ▼

answered Apr 17 '15 at 06:37 PM

avatar image

Pio112233
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question