x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

FBX import problem: skeletal meshes only: multiple segments creates UV failure

I am trying to import a skeletal mesh from Maya 2015 into UE4.7.4

Problem: Import skeletal mesh model has multiple texture problems, possibly due to the multiple UV maps of the skeletal mesh? See attached image: left hand panel is humanoid model in Maya; right hand panel is imported fbx in UE4.

Key details:

1) the model is composed of six different meshes (body, hair, eyes, top, shorts, shoes), each with its own UV map and texture in Maya.

2) if the meshes are detached from the skeleton via , and imported via FBX into UE4 as static meshes, they look just as they appear in Maya, either as individual meshes, or as a single mesh using the 'combine mesh' setting.

3) the same problem occurs if a single component of the mesh and the skeleton are exported by selection and imported into UE4.

I tried to include the Maya binary file as an attachment; however, I get the error that "the file type is invalid". If you'd like to see it, please use the Dropbox public link below:

https://dl.dropboxusercontent.com/u/69815552/Layla_base_rigged.mb

alt text

Product Version: Not Selected
Tags:
more ▼

asked Apr 11 '15 at 06:00 AM in Bug Reports

avatar image

Daeftan
21 4 7 11

avatar image Lovecraft_K ♦♦ STAFF Apr 13 '15 at 02:30 PM

Hey Daeftan -

Can you upload the FBX as well? And feel free to zip the file (even by itself) and you should be able to upload directly here.

Thank You

Eric Ketchum

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I was having the same problem. For me, UNchecking Triangulate when exporting solved the issue.

more ▼

answered Jul 20 '15 at 05:47 PM

avatar image

MaskedApe
161 3 100 12

avatar image Daeftan Jul 20 '15 at 05:56 PM

Hey MA,

Thanks for this.

D

avatar image Vuthric Aug 20 '16 at 11:49 AM

That does it for me too. Thanks.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Daeftan -

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

Eric Ketchum

more ▼

answered Apr 20 '15 at 04:22 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 702 260 736

avatar image Daeftan Apr 20 '15 at 04:40 PM

Eric,

I thought I send you a message with the .fbx, but I must not have hit SEND.

Even after zip, it is still larger than 5MB, so I am including another Dropbox link here to it:

https://dl.dropboxusercontent.com/u/69815552/Layla.fbx

Please let me know what you think. Is this a problem with the FBX exporter from Maya? It seems that if I export the model as FBX, then re-import into Maya, it looks like it has the same texture problem as UE4 does.

Bests,

D

avatar image Lovecraft_K ♦♦ STAFF Apr 20 '15 at 05:39 PM

Hey Darftan -

Thank you for getting back with me. I ran a test on the FBX and cannot find any problems with importing it into Maya or UE4. Layla comes in with no Material errors at all. I will say that I tested in 4.7.5 so you may want to try that if you can. (or 4.7.6 by now). If it is still causing you a problem in the newest engine version can you layout the settings you are using to export the FBX from Maya and the Import settings you are using in UE4.

Hopefully though the new version will fix the issue.

Let me know -

Eric Ketchum

avatar image Daeftan Apr 22 '15 at 01:59 AM

Eric, thanks for looking at it. I can import also to both with no errors. However, when I import to Maya, then export as FBX it then generates the problem I described. Here is a version of my save:

https://dl.dropboxusercontent.com/u/69815552/Layla_maya_save.fbx

I do get a material error when I try to export from Maya. I tried all my usual tricks (e.g., changing all the materials to lamberts/phong, deleting non-deformer history) but I still get the same result.

Any thoughts?

avatar image Lovecraft_K ♦♦ STAFF Apr 22 '15 at 08:51 PM

Hi Daeftan -

I do think that this issue is caused by an export setting in Maya. Can you give me a screenshot / rundown of your export settings you are using as well as what FBX version you are using?

Thank You

Eric Ketchum

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question