x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unable to launch project on iOS built by UnrealRemoteTool

Unreal Engine 4.7.5

iOS 8.3

OS X 10.10.3 (VM)

I followed "Steps for IOS build with UnrealRemoteTool" and I am able to build (test.stub) and deploy to my iPad3. However, nothing happens when I run it (just black screen).

See this line in Xcode console log:

Apr 11 18:11:35 iPad3 test[921] : Assertion failed: HasFoundDataDirectory [File:/UE4/Builds/LYNNFIELD/D/UE4/Engine/Source/Runtime/Core/Private/Internationalization/ICUInternationalization.cpp] [Line: 118]

 ICU data directory was not discovered:
 ../../../test/Content/Internationalization
 ../../../Engine/Content/Internationalization

Looks like it is causing the problem. Can anyone tell what is going on?

I can see that both test/Content(PC & Mac) are empty. Engine/Content is empty on the Mac but has files on the PC.

The console log and 2 crash log files are attached. log.zip

Product Version: Not Selected
Tags:
log.zip (27.5 kB)
more ▼

asked Apr 11 '15 at 11:29 AM in Packaging & Deployment

avatar image

kevterm
71 10 9 14

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

If you are running from xcode you will need to get the content to the device. Easiest is cook on the fly server running on your PC. You can do it with UFE or Game Launcher in the editor, or the command line:

Ue4editor-cmd -run=cook -cookonthefly [-iterate]

Then add this to the ios commandline in xcode to -filehostip=X.x.x.x

(using your PC ip address)

more ▼

answered Apr 11 '15 at 03:30 PM

avatar image

joshbadams STAFF
1.3k 19 7 46

avatar image kevterm Apr 12 '15 at 09:43 AM

Josh,

Thank you for your reply. I tried both "Package Project" and "Project Launcher"; they both failed. I can see from the attached log files that UnrealBuildTool failed (line 572 of UAT_Log.txt). Did I do something wrong?

Kevin

[1]: /storage/temp/38452-logs.zip

logs.zip (14.5 kB)
avatar image Ravlek STAFF Apr 13 '15 at 01:34 PM

Josh is right, you need to either package the project so it cooks the content, or use the cook on the fly server. However, you have a more fundamental issue in that you named your game project "test" A couple of our tools see that in the command line and believe you are attempting to build the test configuration. Try naming the project TestGame or something similar and give that a go.

-Pete

avatar image kevterm Apr 13 '15 at 03:28 PM

Thanks a lot Pete. It works and you just saved my life.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question