x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unreal Tournament Editor Installation Failed, File Corruption

When I was trying to install the unreal tournament editor it was maybe half way done when this error showed up:

"Installation Failed. A file corruption has occurred. Please try again."

If I click resume, it flickers between "initializing" and "resuming" for about 5 seconds and then the same error pops up. When I click remove and then install the same error shows up after about 50%. I have tried manually removing the files its downloading, just encase there were some remnants or files it couldn't remove by itself.

Product Version: Not Selected
Tags:
more ▼

asked Apr 12 '15 at 05:44 AM in Installation & Setup

avatar image

5tickman
6 1 1 2

avatar image OmegaJak Apr 13 '15 at 12:52 AM

I've also been having this same problem ever since the April 1st update. Unreal Engine itself installed just fine, as did Unreal Tournament, but whatever I do, the Unreal Tournament editor will not install. It always gets to exactly 39% downloading, then enters a loop of validating and resuming, resulting in the "A File Corruption has Occured" message. I've tried deleting any associated files I could find on my hard drive (in Appdata and such), but this has changed nothing. I tried uninstalling and reinstalling the launcher, no change. I tried creating a new user on my computer, and downloading through that, same results. (I also tried a VM, but realized that that could never work anyway). I'm out of things to try.

I am on Windows 7 64-bit, running through the Epic Games Launcher.

avatar image Adam Davis STAFF Apr 13 '15 at 04:02 PM

Hi everyone,

Just to be sure before moving on, please check to be sure that your filepath name is not 256 or more characters. This is a hard limit and as DarknesZ pointed out you will have to reduce the length of your filepath to be able to continue. If this is not the error, please comment and let me know what drive you are attempting to install on and check to make sure you have enough space on that drive to install the editor.

avatar image OmegaJak Apr 13 '15 at 08:27 PM

I have tried installing to both of my drives, and in both cases the path length is around 50 characters. I have attempted to install to my C drive, which has 28 GB free, and I have attempted on my D drive, which has 86 GB free. Just some extra info: I did have the Unreal Tournament Editor properly installed to my D drive in the past, but it broke in the April 1st update (or somewhere close to that). Ever since then, it has behaved in the exact same, dysfunctional way.

Edit: I turned on logging and went through the process, here's the log: Dropbox link. (23 MB)

avatar image Adam Davis STAFF Apr 14 '15 at 02:21 PM

can you post a copy of your dxdiag here so I can take a look? You can find this by typing "dxdiag" into your Windows start menu searchbar and save that as a .txt file when you open it. Thank you!

avatar image OmegaJak Apr 14 '15 at 09:03 PM

Sure, here you go: DxDiag. Thanks for looking into this.

dxdiag.txt (49.2 kB)
(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

i had also this problem, try to instll the UT Editor directly on you hard drive (for example c:\UnrealTournamentEditor)

i think it because of the path length, my path lenghts was more than 256 characters, after i downloaded directly under my hdd (it dosnet matter which hdd c:\, d:\ ,..).

i waited until the download was done and the editor has started to install , than i stop the install process, renamed the folder and removed the installation of the editor in the unreal launcher and started a new installation on a path you prefer. than i stop the install again. copied the files downloaded first files to the new folder. !importent! cheack if in the Unreal Tournament Editor folder is a file namend $movedMarker. now just resume you new ut editor installation in the unreal launcher and wait until the installation / verification is done.

launch the editor !!

more ▼

answered Apr 12 '15 at 02:08 PM

avatar image

DarknesZ
114 10 15 19

avatar image OmegaJak Apr 15 '15 at 10:31 PM

Wow, thanks, this actually was the solution for me. Irritating issue, but it's resolved now. Just need to put it directly under C:\, nothing else in the path (or something short like that.

(comments are locked)
10|2000 characters needed characters left

Hi 5tickman,

I took a look at your logs and the problem seems to be with a specific file that has a very long file name. In the meantime, try the solution DarknesZ mentioned. Either use the default path or try installing directly at the C:\ level. Also to learn how to set up a symbolic link check out the tips and tricks sections on the troubleshoot page. I will talk with the UT Team and see if there are any possible solutions for this issue on our end.

-Max B.

more ▼

answered Apr 15 '15 at 02:29 PM

(comments are locked)
10|2000 characters needed characters left

When I try to upload unreal engine editor it says "Please close all instances of unreal tournament editor to continue" Please help me

more ▼

answered Jan 25 '17 at 01:33 AM

avatar image

TANISHQTYAGI
1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question