x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[BUG REPORT] Format text "{index}"

Using {index} in the blueprint "format text" node throws up the following error:

"Internal compiler error inside create execution schedule (site2)"

I searched for hours and fixed it by changing "Index" to "Number".

Product Version: Not Selected
Tags:
more ▼

asked Apr 12 '15 at 08:58 PM in Bug Reports

avatar image

Karner
90 9 10 20

avatar image Ben Halliday STAFF Apr 13 '15 at 04:48 PM

Hi Karner,

I wasn't able to reproduce this behavior in 4.7.5. Are you using a different version of the engine? Does this cause a compile failure, or does this error occur during Play? Can you post a screenshot of the BP setup that produces this error? Thanks!

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

After running through a few tests, this appears to have been resolved in the later versions of the engine. I cannot reproduce this issue in the 4.14.3 version of the engine. Thank you for your time and information.

Make it a great day

more ▼

answered Jan 23 '17 at 07:49 PM

avatar image

Rudy Q ♦♦ STAFF
47.9k 544 132 521

(comments are locked)
10|2000 characters needed characters left

Hey Karner,

We haven't heard back from you in a while, so I'm resolving this post for tracking purposes. If you're still experiencing this bug, please feel free to respond with the information requested above and we can continue investigating. Thanks!

more ▼

answered Apr 17 '15 at 05:26 PM

(comments are locked)
10|2000 characters needed characters left

I found the cause of this bug. If you use a Format Text node, create a {index} pin and attach something to it, then change the index text (to say {i1}... the actual names don't seem to matter, but this is how I replicated it), this will then break the string, but the node the string CAME from (usually a conversion node) will still be solid as if a string is going somewhere. If you then reconnect this to the Format Text field without alt-clicking it to clear it, you get the resulting error.

more ▼

answered Jan 17 '17 at 10:21 PM

avatar image

Zurar
1 1 1

avatar image Rudy Q ♦♦ STAFF Jan 19 '17 at 09:08 PM

Hello Zurar,

I ran a few tests and I was unable to reproduce this issue on our end. I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. What engine version are you currently using when the issue occurs?

  2. Can you reproduce this issue in a clean project?

  3. If so, could you provide a detailed list of steps to reproduce this issue on our end (including any small steps that may have been left out of your original set)?

  4. Could you provide screen shots of any blueprints/settings that may be involved with this issue?

avatar image Zurar Jan 19 '17 at 10:28 PM
  1. Version 4.5.1 (discovered while using Ark: Survival Evolved modified Dev Kit).

  2. Installed UE4.5.1 (non-Ark version) and did reproduce it.

  3. To recreate, I created a new blank project using Engine Version 4.5.1 from Unreal Engine > Library, went into the StarterContent folder, opened Blueprint_WallSconce and created the below Event Graph using the OnClicked event from the static mesh component SM_Lamp_Wall (event itself is irrelevant to the actual issue, but was used as a start point).

Recreation:

  1. Created the below graph (variables Test 1 and Test 2 can have any random string inserted): Step 1

  2. Change t2 to input2 in the "Format" field without detaching strings (notice: string is detached automatically on rename but the previous "from" node is still solid): Step 2

  3. Reattach original "from" node to input2 and compile: Step 3

In step 2 of the process, the node originally connected to t2 is still solid, as if it's leading to something. If you Alt+click on this to clear it, the error in step 3 is prevented. If you do not Alt+Click on it before reconnecting it to the now renamed input2, the error is encountered upon compiling the blueprint.

step1.png (84.7 kB)
step2.png (83.9 kB)
step3.png (109.5 kB)
avatar image Zurar Jan 19 '17 at 11:04 PM

Not exactly sure why I did this with 2 string variables; it will happen even with 1, following the same steps...

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question