Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

[Linux] Cannot build lighting!

I have asked this problem before to no avail. So let me ask again. :) I try to build the level, and all goes well until It does the Lightmass. It gets stuck at 0%. I was doing this offline and I went. "Maybe I need to be online?" And then it started to build fine online. Then a couple of days ago it stopped at 0% online and off. This is really getting on my nerves, so a answer would really be nice. And yes I have opened diffrent projects and loaded one's that used to build. I am using Unbuntu by the way. Help this is a major problem!

Product Version: Not Selected
more ▼

asked Apr 13 '15 at 02:38 AM in Rendering

avatar image

100 11 12 15

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Hi 94,

I've gone ahead and closed your other posts so that all the information is in a single post. It's better to "bump" a single thread after a few days rather than opening multiple threads with all the same information.

Often when Lighting is stuck building at 0% it may appear that it's not working, but often this is just the calculation phase of light builds.

What type of scene do you have? Large, Medium, Small? Do you have a lot of meshes in the scene? Have you increased the lightmap resolutions of a lot of meshes? if so, try lower lightmap resolutions.

Can you try building lighting in one of the template projects, like the first person or third person template?

If lighting builds here then you need to take into consideration some things for your current game that can help improve light builds.

Let me know.



more ▼

answered Apr 13 '15 at 08:52 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 887 101 878

avatar image 94 Apr 13 '15 at 09:35 PM

Sorry for making to many posts... Also the scene was originally somewhere between medium and small. I gave up after 12 hours. Then I tried all the templates... As you can guess they didn't work either. And let me say there was nothing overtly complex in any of those scenes. (old school FPS stuff.) Thanks for answering.

avatar image 94 Apr 13 '15 at 10:08 PM

Okay this one is interesting. I just put all the graphical setting to the lowest they can go. Now it says it built, But when I enter the Level it says all the objects are unbuilt? But when I put it back to my old setting the same old Stuck at 0% problem is back. any ideas?

avatar image 94 Apr 14 '15 at 07:49 PM

Ha Ha! It works now for some reason. don't know how, but it works!

avatar image grimdee Oct 20 '18 at 11:49 AM


avatar image Alex Chozabu P-B Oct 20 '18 at 12:00 PM

@grimdee try my answer below... issue may be caused by several different issues, not just win<->lin

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I actually had a similar issue and I couldn't figure out what was going on. (I had a project in 4.7.6 where the lighting would not build past 0% I let it sit for about 9 hours and it never went up, I am using a small project which usually takes about 10 seconds to build the lighting) I tried adjusting the graphical settings but that didn't work. After trying a number of different things I copied the project files into a new project file. That didn't work either. But immediately after that I closed UE4, Epic Games Launcher and changed the map name (Through my Mac's finder) to a new map name (Before I had it at Map_Beta I changed it to Map_Charlie). And it builds fine now.

The main difference between my issue and 94's was the templates were building for me it was only the one project.

I hope this helps anyone else who is having this issue.

more ▼

answered May 17 '15 at 06:01 PM

avatar image

1 1 2

avatar image Anton Fedoruk Jun 28 '15 at 04:54 AM

I'm having the same issue on Mac (UE4 4.8.1). Closing and opening the editor seems to help.

avatar image Striblezz Feb 28 '16 at 10:17 AM

I just had the same issue on 4.11, and restarting the editor fixed it for me as well. Thanks!

avatar image Wallenstein Jul 30 '16 at 09:30 AM

I ran inot the same problem while experimenting with Hierarchical LOD. The BUILD ALL command had built the LOD meshes and materials but they were not showing in the HLOD subdirectory. I SAVED ALL manyally and then ran BUILD LIGHTING and everything worked

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

For me restart of computer, and restart of launcher didnt work.

LinuxMint 18.1 on Version 4.14

Even when I want to build a completely empty Level, it gets stuck

more ▼

answered Jan 03 '17 at 05:36 PM

avatar image

Martin Zigler
5 3 3 6

avatar image 94 Feb 11 '17 at 01:19 AM

They made a bug entry or whatever about this in another thread I started. Don't know if anything has come of it. https://answers.unrealengine.com/questions/251080/lighting-will-not-build-offline.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I encountered this issue after opening a project started in windows on linux.

For me the solution was to delete all levels builtdata - close the project, open it and rebuild all levels.

Also, delete all generated folders in project. Intermediate, built, etc

more ▼

answered May 02 '17 at 04:34 PM

avatar image

Alex Chozabu P-B
36 3 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question