x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Actors do not replicate when using sessions

I have followed the Multiplayer Shootout showcase and tried to replicate the sessions part for my own project. I can create a (LAN) session, see other sessions and join one. My problem is that, for some reason, the actors do not replicate. If I simply open the map, for 2 players, they replicate without any issues. Is there something else I should do to enable replications when using sessions? Thank you!

Game Instance Blueprint alt text alt text alt text

Game Mode Blueprint alt text

Product Version: Not Selected
Tags:
more ▼

asked Apr 14 '15 at 03:09 PM in Blueprint Scripting

avatar image

ionutt93
1 1 3

avatar image Ben Halliday STAFF Apr 14 '15 at 08:22 PM

Hi ionutt93,

We're going to need to see more information to figure out what might be happening here, I think. Which Actors aren't replicating, the Characters? Do they not replicate on the Client or the Server, or both? You mention that they replicate as expected when the map is open and you Play in Editor with clients set to 2; when does this not happen? A packaged project?

If you can take some screenshots of your Blueprint Graph setups, including your widgets, that you're using, or if you're able to tell me which parts of the Multiplayer Shootout project you're NOT using, we might be able to see what's going on. Thanks!

avatar image ionutt93 Apr 14 '15 at 08:45 PM

Hello, thanks for responding to my question. In the mean time I have identified several other problems within the project. When I try to join a session, it actually has an error: LogNet:Warning: Travel Failure: [LoadMapFailure]: Failed to load package '/Game/Maps/UEDPIE_2_Arena2' And I noticed that the total number of players in the map does not change, it's like each player is playing on a different instance of the map. I've added pictures of the relevant blueprints. Hope this helps! Thank you!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

After further researching the travel failure bug, I learned that the error was caused because I was playing the game inside the editor. I tried the game in Standalone mode and replication works as expected.

more ▼

answered Apr 14 '15 at 09:29 PM

avatar image

ionutt93
1 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question