x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.7.5 Mac] Compiling UE4Game from source

Hi, I'm trying to compile 4.7.5 on mac from Github. The editor compiles without problems, but when I try to compile UE4Game - Mac I get the following errors:

 Malformed block record in PCH file: '/Users/unstable/Documents/Unreal Projects/UnrealEngine/Engine/Intermediate/Build/Mac/UE4Game/Development/Engine/EnginePrivate.h.gch'
 Malformed block record in PCH file: '/Users/unstable/Documents/Unreal Projects/UnrealEngine/Engine/Intermediate/Build/Mac/UE4Game/Development/Renderer/RendererPrivate.h.gch'
 Malformed block record in PCH file: '/Users/unstable/Documents/Unreal Projects/UnrealEngine/Engine/Intermediate/Build/Mac/UE4Game/Development/Core/CorePrivatePCH.h.gch'

I had no problems in building the same target in previous versions. Any suggestions?

Product Version: Not Selected
Tags:
more ▼

asked Apr 14 '15 at 06:42 PM in Installation & Setup

avatar image

devel.bmad
439 43 49 65

avatar image AndrewHurley Apr 14 '15 at 09:42 PM

Hello devel.bmad,

We are currently looking into this issue and we appreciate your patience while we test.

Just in case I need it in the future, would you mind providing me with your system specifications?

Regards,

Andrew Hurley

avatar image devel.bmad Apr 14 '15 at 10:06 PM

Of course. I'm using a MacBook Pro (Retina, 15-inch, Mid 2014) with OS X v10.10.2

Processor: 2,8 GHz Intel Core i7 Memory: 16 GB 1600 MHz DDR3 NVIDIA GeForce GT 750M 2048 MB

Please let me know if I can help you.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Did you try a clean rebuild? Did you possibly upgrade Xcode recently?

I would suggest deleting this directory:

/Users/unstable/Documents/Unreal Projects/UnrealEngine/Engine/Intermediate/Build/Mac/UE4Game/

Josh

more ▼

answered Apr 20 '15 at 09:38 PM

avatar image

joshbadams STAFF
1.3k 19 7 46

avatar image devel.bmad Apr 20 '15 at 09:59 PM

Hi Josh, I completely deleted the source tree and downloaded it again from scratch from github, and now I can compile UE4Game without problems. The issue was probably related to upgrading from a previous version of the code. AndrewHurley in the post above wrote that he was able to reproduce the issue, it would be interesting to understand if he was upgrading too.

avatar image joshbadams STAFF Apr 20 '15 at 10:02 PM

His error was something else (a failure to launch the executable). Building worked for him.

Basically, PCH files are not valid across clang versions. Or possibly it was an issue where it was compiled with old UBT with different settings than current UBT, but I would expect it to recompile the PCH files.

PCH files are strange black boxes that are hard to debug :)

Josh

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey again devel.bmad,

I attempted to compile the source code on the Mac we have here in house which is close to the exact model you are using as well. I was able to compile the 'UE4 - Editor - Mac' filepath without trouble, but like yourself, was unable to compile the 'UE4 - Game - Mac' filepath. Although I did not receive the same error message you did, I went ahead and entered a bug report for this issue.

We appreciate your patience while we work on finding a solution and issuing the fix in an upcoming release. If you have any other questions please do not hesitate to ask.

Regards,

Andrew Hurley

more ▼

answered Apr 16 '15 at 09:31 PM

avatar image devel.bmad Apr 16 '15 at 09:44 PM

Ok thank you. Please keep me posted on the subject if there are any news.

avatar image AndrewHurley Apr 23 '15 at 05:53 PM

The error message I was getting was resolved by simply setting up a new clean build. After, I was able to compile UE4- Editor as well as UE4 - Game.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question