Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Project gets corrupted after moving from 4.61 to 4.7. Causes editor to cash on exiting

The crash happens on exiting or closing 100% of the time with my project. Also, when launching my game through USB to iPhone5 it says Launch Fail but if I click the icon the game will have been updated. It never happens when creating a new project. I reproduced the bug on my Windows 7 machine as well as on my Mac Pro. I have tried migrating my content into a new scene but that did not work. I tried renaming all my folders and manually fixing all broken links but nothing helps. This is a Blueprint, based game. I am desperate to fix this so I can update my game so I can move on to the next game but this bug has me stalled.

Product Version: Not Selected
more ▼

asked Apr 15 '15 at 10:42 PM in Bug Reports

avatar image

61 6 6 5

avatar image Ben Halliday STAFF Apr 16 '15 at 03:20 PM

Hi Stache,

Do you get a Crash Reporter dialogue when this crash occurs? If so, please copy the information and paste it in a reply here, and make sure you submit the report. Please also zip and attach the log from your project after this crash occurs. This can be found in your project folder under \Saved\Logs. Thanks!

avatar image Stache Apr 17 '15 at 09:38 PM
avatar image Ben Halliday STAFF Apr 17 '15 at 09:43 PM

Thanks, but we need the crash log from the project. This appears to be the CrashReportClient log.

avatar image Stache Apr 18 '15 at 01:13 PM

link text

Strange, my project does not have the "Saved\Logs" folder or any log files. I copied and pasted the crash report into a text file

avatar image Stache Apr 17 '15 at 09:44 PM

Thank you Ben, I was not able to paste the crash log directly. I think it was to big. Hopefully, the zipped log attached above will work and is the correct file.

avatar image Ben Halliday STAFF Apr 20 '15 at 03:40 PM

Ah, I'm sorry, didn't realize this was on the Mac. In OSX, you can find the logs in the Library:

~/Library/Logs/Unreal Engine/ProjectName

(Note that /Users/yourusername/Library is invisible. Hold the alt-key and from the finder menu select Go->Library)

It looks like this is a known bug (UE-13804), and any additional information we can add to the report will aid in getting it fixed as soon as possible. Thanks!

avatar image Stache Apr 21 '15 at 08:12 PM
dis_free.log (18.9 kB)
avatar image Ben Halliday STAFF Apr 21 '15 at 08:18 PM

Thanks! This definitely looks like the same bug to me. The developer looking into it requested a repro project. Would you be able to upload this project somewhere and get us a download link? You can send it to me privately over the forums if you'd prefer:


avatar image Ben Halliday STAFF Apr 21 '15 at 08:19 PM

If you could upload the Windows version of the project, that would probably be easier for us.

avatar image Stache Apr 21 '15 at 11:54 PM

PM sent with download

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Stache,

Thanks for letting me take a look at the project! I can confirm that this is the same crash we had reported as UE-13804, and updated the bug to include your project information. I also emailed the developer looking into it so he can take a look if necessary, but it appears the bug is already fixed internally as I don't get the crash after closing the editor in our main internal build.

The next release will be 4.8, and the project shouldn't crash the editor in that version. I believe we'll be doing a Preview release for it soon, so you can test it there. If you need to finish up now, you can try building the latest Promoted branch from GitHub.

I wasn't able to reproduce the build failure on the iPhone, though. I only tried through Windows, though. If you're still having that problem on the Mac in 4.7.6, try on the PC and see if the same problem occurs.

more ▼

answered Apr 22 '15 at 09:04 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question