Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How do I include the leap-motion-plugin into an existing project?

I'm working on a project in UE4.7.5 and I want to use Leap Motion in the project. I downloaded the plugin and copied the LeapMotionController-folder into the plugin-folder of my existing project. I could now enable the plugin in the projectsettings. UE4 wanted to restart to use the plugin so I tried it. But then the message "The following modules are missing or built with a different engine version: UE4Editor-LeapMotionController.dll Would you like to rebuild them now?" appeared. So I pressed Yes. And now the error-message "MyProject could not be compiled. Try rebuilding from source manually" appeared. I don't know what to do now to make Leap Motion work. I can't find the missing module anywhere on my computer. And I don't know how to rebuild from the source manually.

Product Version: Not Selected
more ▼

asked Apr 16 '15 at 02:26 PM in Using UE4

avatar image

0 2 4 5

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I solved the problem. If someone wants to know how just ask.

more ▼

answered May 06 '15 at 10:30 AM

avatar image

0 2 4 5

avatar image capatto May 08 '15 at 01:28 AM

Hello Plasmaschnee I am suffering from this problem, can you help me? tks

avatar image matewfeel May 11 '15 at 01:07 AM

hey ! i found myself in the same situation, could you explain how you fixed that ? thank you :)

avatar image Plasmaschnee May 11 '15 at 01:27 PM

I followed these instructions until after the download from Github. https://developer.leapmotion.com/documentation/unreal/index.html. Then I used the setup.bat in the directory. After that there was a UE4.sln in the directory which I used with Visual Studio. After it built the whole Unreal Engine new in Visual Studio I launched it clicking on "Local Windows-Debugger" and it started Unreal Engine 4. Now it let me choose the project I wanted to open with this version of UE4. I chose my project and it told me, that I needed to convert it to the new UE4-Version. There also is the option to open a copy of the project so that you have one version in 4.7 and the other in the version with the plugin. After the project was open I continued to follow the instructions "Enable the plugin" from the same page as before. To find the "Leap Motion Controller" I followed this guide: https://developer.leapmotion.com/documentation/unreal/unreal/Leap_Unreal_Using_Plugin.html I hope that helps. If it is still not working tell me exactly where it didn't work and I will try to help.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question