x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Camera Issues in 4.7.5

Hello Everyone, I have run into a small issue with my initial camera rotation. If I setup the camera looking a normal way, it is completely inverted and will not show. To get my camera looking straight out of my car, I had to rotate it 90 degrees facing the ground. I have included a picture with the skeletal mesh on the left monitor and the game from my right monitor. Any help on this weird rotation would be greatly appreciated! alt text

Product Version: Not Selected
Tags:
more ▼

asked Apr 16 '15 at 04:43 PM in Bug Reports

avatar image

Aggresivenapk1n
1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

I had a similar issue and it was because of the skeleton root. Don't know why the camera takes the root transform, so to fix it you can check your root or a quick solution go to your camera -> Sockets -> Parent Socket ( and select the root element (in my case the car body) ) after that, the camera should move to the root position and now you can move it in the viewport. Hope is enough clear and works.

more ▼

answered Jul 06 '15 at 01:43 PM

avatar image

darorck
121 8 10 13

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey Aggresivenapk1n,

Try deleting your camera actor and adding a new one, and be sure the 'Transform' is set to 'Relative'. A good way to troubleshoot this issue would be to have a look at the vehicle blueprint of the 'Advanced Vehicle' template. I am assuming this is the project template you are working within already, so that would be a good place to reverse engineer to see where your blueprint differs from the default vehicle blueprint.

Use the image below as a reference for places to check where your camera rotation could be getting overridden or changed.

Vehicle Blueprint

alt text

I have highlighted areas of importance which can affect rotation of your camera. Let me know if you figure out the solution or if you need further assistance.

Cheers,

Andrew Hurley

advehiclebp.png (686.4 kB)
more ▼

answered Apr 17 '15 at 04:26 PM

avatar image Aggresivenapk1n Apr 22 '15 at 03:39 PM

Thank you so much Andrew! I will check this in a few moments!

avatar image Aggresivenapk1n Apr 22 '15 at 04:29 PM

Hmm, It did not work. Apparently they were already set to the settings you provided :/ I made sure to set the spring arm and the camera to relative transform and untick use pawn control rotation, but I am getting the same flip floppy camera settings. Could it be the rotation from the export? I downloaded the model online and then opened it in max, and its base rotation was nose down. I fixed the rotation in 3ds max then exported to fbx like I normally do. I didnt have this problem when I was exporting skeletal mesh animations for the 3rd person tutorial. Very weird that I am having them here too

avatar image AndrewHurley Apr 22 '15 at 06:36 PM

The base rotation could definitely have something to do with the issue. Especially if the car mesh is the root of the camera actor in your blueprint. Go into your external modeling program, be sure it is rotated correctly and it's pivot and default world location is at the origin. Then re-export the model and import it back into the engine.

Now try adding the camera boom and camera actor to your blueprint and see if these changes had an effect on the camera rotation at all. If you are still stuck and cannot seem to get the rotation right, let me know and I have a few more suggestions that you can try to fix the issue.

Cheers,

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This may be too late but for others who are facing a similar problem and came to this post like me, it's a simple problem that can easily be solved.

Chances are you may have rotated your model to face the correct orientation in your modelling program but may have a disoriented pivot. For me, I'm using 3ds max and sometimes I model in different viewports (ie. created a cylinder in one view, then rotating the polygon later inside Edit Poly to face another direction) so you need to make sure that: 1) Your model is facing the correct axis (X - forward etc...) 2) Go to 'Hierarchy' tab and select 'Affect Pivot Only' and check your pivot's orientation making sure it's the same as your model's orientation

I don't use Maya or other software so sorry if this isn't helping.

more ▼

answered Jul 05 '15 at 05:18 PM

avatar image

FZBK
46 3 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question