x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UMG Events don't execute in packaged game

I have a lot of code similar to this in the event graph of various UMG event graphs:

alt text

It all works fine when I run it in PIE, but no event ever gets executed when I "launch" or package it. It doesn't matter if I use EventTick, EventConstruct or some custom event - never gets executed.

I don't know what else to tell you... I always compile selecting Development.

Do you have an idea on why it doesn't get executed?

Product Version: Not Selected
Tags:
tick.png (21.8 kB)
more ▼

asked Apr 17 '15 at 01:50 PM in Bug Reports

avatar image

Deventico
209 19 20 30

avatar image Deventico Apr 17 '15 at 02:26 PM

EDIT: Wrong answer below:

Huh, I got it. Turns out all you have to do is deleting your Binaries, Build, Intermediate and Saved folders, reopen the editor and repackage the game.

... I hate blueprint bugs.

EDIT: See problem in comments

avatar image Deventico Apr 17 '15 at 02:48 PM

Ups, turned out I was wrong!

Actually, it works when you delete those folders and launch the game.

If you package the game, it doesn't - regardless of wether you deleted the folders before or not. And after building the game once, launching doesn't work either.

avatar image Deventico Apr 17 '15 at 05:49 PM

Seems like this issue does not appear in new simple projects.

I just uploaded my whole game so if someone from epic wants to have a look at it, just tell me for which E-Mails to unblock the download.

avatar image Deventico Apr 20 '15 at 08:16 PM

I just checked. Not working in 4.7.6.

avatar image Deventico Apr 20 '15 at 08:18 PM

Also I just noticed: KeyDown functions don't work for me, when the game is packaged. I set them up like this and they work, but they don't when the game is packaged.

I wonder if that is related.

avatar image Deventico May 07 '15 at 02:38 PM

It's been 20 days and I don't know what to do. I even uploaded the game!

Is there anything I could test, try or do?

Any suggestion at all?! Please!

avatar image Rudy Q ♦♦ STAFF May 20 '15 at 07:37 PM

Hello Deventico,

I have a few quick questions for you that will help narrow down what issue it is that you are experiencing.

Quick Questions:

  1. What platform are you packaging for?

  2. Is the project that you are having issues with been upgraded from older versions of the engine?

  3. I see that you mentioned providing your project, could you point me to where I can find it to take a closer look?

avatar image Deventico May 20 '15 at 08:02 PM

Thank you!!

  1. I'm packaging for windows

  2. Yes, the project started around... 4.4 I guess? About october last year.

  3. Yep, the project is still uploaded here.

I deleted all unnecessary stuff, you should be able to build the Binaries yourself, if necessary.

Please tell me when you finished the download, so I can make the access private.

Thanks again!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Deventico,

After looking through your project I have found that you appear to have circular dependencies in your Character blueprint. This could be what is causing the errors that you are seeing. The dependencies that I have found appear to be those between your Character and your soldiers. After reading your post about how things work one time through after deleting your saved files, this theory becomes even more likely. I hope that this information helps.

Make it a great day

more ▼

answered May 22 '15 at 02:19 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

avatar image Deventico May 31 '15 at 08:18 PM

Hm...

I deleted all circular dependencies between the character and the soldiers (MyCharacter has references now to the soldiers, but not the other way round) and checked for correctness using the reference viewer.

But that wasn't it. Blueprint events still work in editor and still fail when packaged.

avatar image Deventico Jun 01 '15 at 07:07 PM

I have searched for more circular dependencies and actually found some, that solved some problems in some widgets. Not all - but I'll keep searching for circular dependencies.

Could you explain what's the state of circular dependencies right now? Should they work and are being fixed? Or is it recommended not to use them? Both?

avatar image Deventico May 31 '15 at 08:19 PM

After reading your post about how things work one time through after deleting your saved files

In my comment I stated explicitly, that this theory is wrong. This approach only works when I launch the game. When I package, it never works.

avatar image Rudy Q ♦♦ STAFF Jun 01 '15 at 09:48 PM

Hello Deventico,

I revisited your project and I was able to to the UMG to function.I did this by snagging the current widgets that are being displayed on screen and placing them as children into a new master widget. I hope that this workaround may prove useful for your project.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question