x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Multiple Steam Problems: Can't build project, Achievements Not working .etc

Hey everyone.

I'm currently having MAJOR problems getting Steam to work with my Unreal Engine 4.

I've tried both these two guides: https://wiki.unrealengine.com/Steam,_Using_the_Steam_SDK_During_Development#Github_Engine_Builds_vs_Retail_UE4_Builds and this one https://docs.unrealengine.com/latest/INT/Programming/Online/Steam/index.html

And I've tried to use the Binary version of steam and the Source version.

Now; The Steam Overlay only appears in Standalone in the BINARY version (Even after following ALL of the relevant steps in both tutorials).

However, when I try to build; I get this issue (ATTACHED: ).

And so I can't build the project.

Not only that, But I try these steps (HERE: [url]https://forums.unrealengine.com/showthread.php?55560-Tutorial-Steam-Achievements[/url]) to get achievements working (I have the achievement on my Steamworks and published) however it always fails to both cache achievements and write achievements.

I noticed the Output log also says stuff like: " steamworks SDK not found in ThirdParty/Steamworks/Steamv132/sdk" even though it's definately there.

I just don't know what the heck I'm supposed to do :(

Product Version: Not Selected
Tags:
more ▼

asked Apr 17 '15 at 11:37 PM in Packaging & Deployment

avatar image

KITATUS
2.3k 98 84 398

avatar image KITATUS Apr 18 '15 at 09:17 AM

I've now got "LogModuleManager:Warning: ModuleManager: Unable to load module 'OnlineSubsystemSteam' because the file 'C:/Users/Ryan/Desktop/UnrealEngine-release/Engine/Binaries/Win64/' was not found. LogOnline:Warning: Unable to load default OnlineSubsystem module Steam, using NULL interface"

Even though, Obviously Engine / Binaries / Win64 is definately there. I just have no idea what the SteamSubSystem wants to do there.

avatar image KITATUS Apr 20 '15 at 06:53 PM

I've been trying and trying and making no progress here. I've scowered the Answerhub / Documentation many times and I'm making no progress :( It's really disheartening. Any one got any ideas?

avatar image KITATUS Apr 23 '15 at 05:38 PM

Adding to progress: It seems in Standalone, I've made progress (In Binary version stangely enough). I can get the player's Steam name but I can't cache / write achievements :(

avatar image KITATUS Apr 24 '15 at 07:41 PM

Adding to even more progress: I've now got Steam working in editor but no matter what Achievements WON'T work, Even on builds I throw up onto Steam.

And this is the thing I want from Steamworks the most; The achievements :(

avatar image Shadowriver Apr 24 '15 at 09:47 PM

Did you check if config in packages sets probably?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Yeah; I've been following this thread and so far we've temporarily got things working: https://forums.unrealengine.com/showthread.php?67565-Steam-Setup-Utility&p=278766#post278766

more ▼

answered Apr 24 '15 at 10:26 PM

avatar image

KITATUS
2.3k 98 84 398

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question