x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Android Build Failed

I had posted a similar question a few weeks back, but got no reply, so I'll try posting again. I've been trying to package my game for Android, but no matter what I do, I keep getting the build failed error. I've tried looking it up online, but I still cannot build my game. I've attached the log file this time.

Log

Product Version: Not Selected
Tags:
uat_log.txt (363.2 kB)
more ▼

asked Apr 20 '15 at 07:10 AM in Packaging & Deployment

avatar image

nitishmisra
1 1 3 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Sadly, the actual error isn't printing:

 UEDeployAndroid.RunCommandLineProgramAndThrowOnError: Preparing native code for debugging...
 UEDeployAndroid.RunCommandLineProgramAndThrowOnError: 
 Running: F:/NVPACK/android-ndk-r9c/ndk-build.cmd APP_ABI="armeabi-v7a " NDK_DEBUG=1
 BuildCommand.Execute: BUILD FAILED
 Program.Main: AutomationTool terminated with exception:
 Program.Main: Exception in UnrealBuildTool: ERROR: F:/NVPACK/android-ndk-r9c/ndk-build.cmd failed with args APP_ABI="armeabi-v7a " NDK_DEBUG=1

You should go into the /Intermediate/Android/APK directory and run that command (F:/NVPACK/android-ndk-r9c/ndk-build.cmd APP_ABI="armeabi-v7a " NDK_DEBUG=1) and see if you see any more output.

Josh

more ▼

answered Apr 20 '15 at 04:04 PM

avatar image

joshbadams STAFF
1.3k 19 7 46

avatar image nitishmisra Apr 21 '15 at 05:13 AM

Hi, thanks for replying. I did that, and here's what I'm getting

 C:\WINDOWS\system32>F:/NVPACK/android-ndk-r9c/ndk-build.cmd APP_ABI="armeabi-v7a
  " NDK_DEBUG=1
 Android NDK: Could not find application project directory !
 Android NDK: Please define the NDK_PROJECT_PATH variable to point to it.
 F:\NVPACK\android-ndk-r9c\build/core/build-local.mk:148: *** Android NDK: Aborti
 ng    .  Stop.

Press any key to continue . . .

avatar image joshbadams STAFF Apr 21 '15 at 07:54 PM

You are not running from the proper directory. You need to do this first:

 pushd <PathToProject>\Intermediate\Android\APK

something like:

 pushd "D:\Unreal Engine\My Projects\AwesomeProject\Intermediate\Android\APK"
 
avatar image nitishmisra Apr 22 '15 at 04:51 AM

Oh ok! I did what you said, and this is the output I got.

 Microsoft Windows [Version 6.3.9600]
 (c) 2013 Microsoft Corporation. All rights reserved.
 
 C:\Users\Nitish>pusd C:\Users\Nitish\Documents\Unreal Projects\Blockmania 4.7\In
 termediate\Android\APK
 'pusd' is not recognized as an internal or external command,
 operable program or batch file.
 
 C:\Users\Nitish>pushd C:\Users\Nitish\Documents\Unreal Projects\Blockmania 4.7\I
 ntermediate\Android\APK
 
 C:\Users\Nitish\Documents\Unreal Projects\Blockmania 4.7\Intermediate\Android\AP
 K>F:/NVPACK/android-ndk-r9c/ndk-build.cmd APP_ABI="armeabi-v7a " NDK_DEBUG=1
 [armeabi-v7a] Gdbserver      : [arm-linux-androideabi-4.6] libs/armeabi-v7a/gdbs
 erver
 [armeabi-v7a] Gdbsetup       : libs/armeabi-v7a/gdb.setup
 [armeabi-v7a] Prebuilt       : libUE4.so <= jni/armeabi-v7a/
 [armeabi-v7a] Install        : libUE4.so => libs/armeabi-v7a/libUE4.so
 Press any key to continue . . .
avatar image joshbadams STAFF Apr 22 '15 at 03:20 PM

Well frustratingly that looks all good (except for the Press any key to continue at the end - when I run ndk-build, I don't get that happening). Maybe that is actually not coming from ndk-build?

Basically, I can't tell what is happening, because command that your log shows is failing is working correctly when you run it...

avatar image nitishmisra Apr 23 '15 at 12:16 PM

Oh! Is there anything else I could show you that could give you an idea as to what's wrong? For starters, I didn't install UE4 in the default location, neither the android SDK files (The default location is C, but I installed it in F, since I didn't have space in my C drive), but I set it in the project settings. Could that be on any use?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello ! I am experiencing the same error while compiling Unreal Engine on Android.

Doing the same command you recommended, I have this error. Could you please help me resolve it ?

D:\UnrealEngine\unrealengine-custom\Engine\Intermediate\Android>C:/NVPACK/android-ndk-r11c/ndk-build.cmd failed with args APP_ABI="armeabi-v7a " NDK_DEBUG=1 Android NDK: Could not find application project directory ! Android NDK: Please define the NDK_PROJECT_PATH variable to point to it. C:\NVPACK\android-ndk-r11c\build\..\build\core\build-local.mk:151: *** Android NDK: Aborting . Stop.

Thanks !

more ▼

answered Jul 14 '16 at 04:25 PM

avatar image

rubanmauve
1 3

avatar image Samantha Sutton ♦♦ STAFF Jul 15 '16 at 01:37 PM

Please submit your own AnswerHub thread for additional assistance. This is an older thread and likely the issue is not the same.

Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

hey guys, I had the same problem when I 'am trying to deploy my game on my tablet android 5.1 (API 22) so this is what I did : - Project Settings > Android > - check Support arm64 [aka arm64-v8a]

alt text

just that and then I had the Gradle problem I just unchecked the "Enable Gradle Instead of Ant" alt text

Hope this helps :)

ue4-fix.png (101.4 kB)
ue4-fix-gradle.png (43.6 kB)
more ▼

answered Dec 26 '17 at 09:52 AM

avatar image

The Dark Light
11 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question