x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Target Point -> Get World Location = Crash Package Build

What: Blueprint Actor moves to 0,0,0 or crashes the packaged build.

Platform: Windows OS 7

Branch: Unreal Launcher

Build version: 4.7.5 and 4.7.3

Project Package: Windows

Problem: "Get World Location from a Target Point actor will crash the game or returns location 0,0,0. Only in packaged build, not in editor."

How to solve this:

  • Do not use: Target Point -> Get World Location

  • Instead use: Target Point -> Get Actor Location

How to solve this

One of my teammates used GetWorldLocation and at certain point the packaged build did not work anymore. I happend to found out it was the target point, but we did not realized it was due Target Point -> Get World Location.

I just happend to found out this issue was already made in dec 2014: https://answers.unrealengine.com/questions/152231/target-point-crash-get-world-location.html

Attached:

AppCrash_UE4-MyTargetPoin_9ad4cc9462968864c144517b815289935484ab7_cab_1b3033dc.zip Clean Target Point Project Source 4.7.5.zip

Product Version: Not Selected
Tags:
more ▼

asked Apr 20 '15 at 04:53 PM in Bug Reports

avatar image

Jeisu
20 3 4 7

avatar image wittlief ♦♦ STAFF Apr 23 '15 at 06:32 PM

Hi Jeisu,

The GetWorldLocation setting to zeroes is a known issue for mobile, is that the platform for which you are packaging? I did not see a packaged version in your zipped project, only the uproject. Does the location reset when you play in editor on the mobile preview?

What is more worrisome however are the crash occurrences, are you able to reproduce the crash with any consistency? If you are able to reproduce the crash, could you include any editor or (if for mobile) logcat logs for the crash?

Thanks very much!

avatar image wittlief ♦♦ STAFF Apr 28 '15 at 03:24 PM

Hi Jeisu,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance. Thank you.

avatar image Jeisu Apr 28 '15 at 03:54 PM

Hey wittlief,

Thanks for the reminder. I was out of office so I have not been able to give more feedback as you requested.

In short: - Project is for windows (not mobile). - There was a error in the project log but since this is a clean project I will test this tomorrow and add the log too.

Tomorrow I have time to get back on this issue again and will report more reports as requested.

Cheers.

avatar image Jeisu Apr 29 '15 at 09:37 AM

Hey wittlief,

I have added the crash log as requested and saw in the crash log that there is some stack overflow in UObject.h. Since I do not have the source version of the engine I have no clue what may cause it and how to fix it. I have also updated the description and added that this problem occurred for the platform Windows.

I was not able to upload a packaged build due 201MB filesize and 5MB upload limit. So you have to package the project yourself, my excuses for this.

I hope I have reported enough information for you for further investigation. If you miss anything feel free to let me know.

Cheers.

avatar image wittlief ♦♦ STAFF May 04 '15 at 08:23 PM

Hi Jeisu,

I have used your project to try and reproduce the crash in binary editor 4.7.6. When I play in editor I can see the BP_Box move as intended.

I unlinked the Get Actor Location node and only used the Get World Location node. I was able to package for Win 64 without error, however when I ran the project .exe I just get a black screen and no crash. Had you seen this behavior in your project at any point?

avatar image Jeisu May 08 '15 at 02:14 PM

Hey wittlief,

Yes, that behavior is correct. Black screen and no crash when running project .exe. This only occurred in levels which uses this BP node.

Cheers.

avatar image wittlief ♦♦ STAFF May 11 '15 at 05:23 PM

ok, then I am a bit confused as above you stated this was the issue:

Problem: "Get World Location from a Target Point actor will crash the game or returns location 0,0,0. Only in packaged build, not in editor."

What node causes the crash in your packaged build if not the Get World Location one?

avatar image Jeisu May 13 '15 at 11:43 AM

Hey wittlief,

Target Point Actor > "Get World Location" = Causes black screen and can't continue to start the level. Since I was not sure if this is a crash or a bug, the application doesn't run normally as expected, I have reported this as a crash.

avatar image wittlief ♦♦ STAFF May 14 '15 at 06:44 PM

Hi Jesiu,

A fix to a similar issue to yours should have been included in the 4.8 preview 2 update. Can you try making a copy (do not convert in place) of your project and attempting the same blueprints setup in the preview and see if you're seeing the same issue?

Thanks!

avatar image Jeisu May 19 '15 at 05:52 PM

Hey wittlief,

Thanks for the mention. I will try to check it out this week. I hope to have results before the weekend.

Cheers.

avatar image Jeisu May 21 '15 at 03:41 PM

Het wittlief,

I have tried it with Unreal Engine 4.8 Preview 3, and noticed some extra changes in the nodes (See the screenshot with the red square as highlight). After package the project, I have no black screen anymore. Except the Platform still moves to Location 0,0,0.

alt text

screenshot_79.png (113.0 kB)
(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Jeisu,

I have more information about the SpriteComponent location issue. This is by design; the SpriteComponent will soon not exist in packaged builds (for perf reasons), so you have to use the RootComponent instead.

Hope this helps!

more ▼

answered May 28 '15 at 01:43 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question