x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Warning: r.RenderTargetPoolMin exceeded 432/400 MB

Every time I do anything (click anywhere in the content browser, compile a BP, click anywhere in a BP Graph) I get the message

"LogRenderTargetPool:Warning: r.RenderTargetPoolMin exceeded 432/400 MB (ok in editor, bad on fixed memory platform)"

in the Output log (which I always have opened on my third monitor).

I have no idea what this means, but it's annoying.

Product Version: Not Selected
Tags:
more ▼

asked Apr 20 '15 at 08:50 PM in Bug Reports

avatar image

John Alcatraz
1.3k 61 139 128

avatar image vodkins Apr 22 '16 at 11:41 AM

Got the same error message this day. It appears every time when i exit PIE or Standalone play. Its too strange, because i didn't added any real actors content to the levels at all - i am currently only working with Blueprints (for creating Menus). The only visuals i have added - clickable boxes and their texts for menus. But even yesterday that error was not present. What i did today is just began a new menu for Options/Setting (actually duplicated my previously created Main Menu).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first

Hello -

Recently we lowered the level from warning to something lower. It's just good to know that the pool size is exceeding and it might cause minor stalls and a lot of video memory. You can run "vis" in the Output log to see what is allocated (Might be the screen resolution or many ReflectionCaptureActors). With "r.RenderTargetPoolMin=500" in the consolevariables.ini (or in console "r.RenderTargetPoolMin 500 ") you could prevent the printout.

Thank You

Eric Ketchum

more ▼

answered Apr 20 '15 at 09:18 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.6k 703 260 737

avatar image John Alcatraz Apr 20 '15 at 09:23 PM

Thanks! But if I run "vis", it says only 100/400MB is allocated (and directly after the vis output I get the warning mentioned above again). I don't use any ReflectionCaptureActors and the Screen Resolution in the Editor is not really high, I have a 1080p screen. I have one SceneCapture2D in my Level which renders to a RenderTarget2D with a resolution of 2048x2048, but this (hopefully) does not allocate 432MB of VRAM!

avatar image John Alcatraz Apr 20 '15 at 09:25 PM

This is the output I get from "vis":

link text

output vis.txt (5.7 kB)
avatar image Lovecraft_K ♦♦ STAFF Apr 21 '15 at 01:20 PM

Hi -

No that one screen capture should not, can I ask what video card and driver you are running currently? Also, does resetting the r.RenderTargetPoolMin to 500 still produce the warning in your logs?

Thank You

Eric Ketchum

avatar image John Alcatraz Apr 21 '15 at 03:10 PM

I have a AMD Radeon HD 7850 with Catalyst 14.4 driver. I know it's one year old, but the newer versions are not compatible with some software.

After setting the r.RenderTargetPoolMin to 500 I don't get the warnings in the log.

avatar image Lovecraft_K ♦♦ STAFF Apr 21 '15 at 05:09 PM

Hi John -

Instead of just the "vis" command, try using the "visRT" command, a window should pop up and see if the total there is at 432. visRT breaks down all render targets in the engine currently running.

Let me know -

Eric Ketchum

avatar image John Alcatraz Apr 21 '15 at 08:59 PM

Thanks!

With visRT I indeed see all the RenderTargets and it says 408MB allocated... It seems the translucent Water Material from the Epic Water Examples is using a lot of RAM.

alt text alt text

btw, if I click on one of the names on top, for example "size", the engine crashes.

avatar image Lovecraft_K ♦♦ STAFF Apr 22 '15 at 04:25 PM

Hi John -

Thank you for the report of the crash. I have entered a report, UE-14237, for reference, and will let you know as soon as we have a successful fix for the issue.

Thank You Again -

Eric Ketchum

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question