x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Launcher installed but will not open. msvcp120 error

I downloaded the launcher and tried to run it, but it gives me an error such as this: alt text

I have tried to make a logfile, to no avail, but have included my dxdiag file link text. I do have a GeForce 745m in the laptop but dxdiag doesn't seem to recognize it, unless i am missing it.

Thank you in advance

Product Version: Not Selected
Tags:
launcher_error.jpg (59.6 kB)
dxdiag.txt (81.6 kB)
more ▼

asked Apr 22 '15 at 04:44 AM in Installation & Setup

avatar image

Neofuuma
1 1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Neofuuma,

This looks like a problem with the Microsoft Visual C++ 2013 redistributables installation.

Could you try installing/reinstalling it?

http://www.microsoft.com/en-us/download/details.aspx?id=40784

I'd recommend re-installing both the x86 and x64 ones, just to be sure everything is in check for you system in general anyway.

Let us know if that helps!

more ▼

answered Apr 22 '15 at 10:46 AM

avatar image

leighswift STAFF
1.8k 38 136 42

avatar image Neofuuma Apr 22 '15 at 12:58 PM

installed and reinstalled both, still having the same error. Even tried the repair button on both installations.

avatar image 0xDEADBEEF STAFF Apr 23 '15 at 04:23 PM

Sorry for the late reply. I have seen issues where the redist repair options do not overwrite some files. Perhaps you can try this:

  1. Download the Win64 version of the Microsoft Visual C++ 2013 redist from here(you probably already have it): http://www.microsoft.com/en-us/download/details.aspx?id=40784

  2. Find and backup your current C:\Windows\System32\MSVCP120.dll. You can do this by renaming it to MSVCP120.dll_BACKUP

  3. Run the repair option on the redist you downloaded.

  4. If a new MSVCP120.dll was added try running the launcher. If not, restore your backed up file.

avatar image Neofuuma Apr 23 '15 at 05:15 PM

OK, i tried this method, renaming the old msvcp120, and using repair, but it seems to have put the same file back in there. The msvcp120.dll I have shows a date of 10/4/2013 and 645kb, same as the previous file. Launcher still fails to open, giving the same error

avatar image 0xDEADBEEF STAFF Apr 30 '15 at 07:59 PM

Sorry for the delay. This is a bit of an odd issue and I wanted to get some feed back from the people here before making any drastic suggestions. Perhaps we can collect a bit more info to help us narrow the problem.

First, Do you run any virus protection software? Second, can you post a screenshot of the various Microsoft Visual C++ redistributables you have installed? You can find this in Control Panel under Programs and Features. It will look something like this(Note this is on my Win7 machine but Win8.1 should look similar).

alt text

capture.png (123.9 kB)
avatar image Neofuuma Apr 30 '15 at 08:17 PM

No worries on the delay 0xDEADBEEF, I appreciate the time you are taking to help me resolve the issue! Yes, I run Webroot SecureAnywhere on my laptop. And here is my list of the MSVCPs in my control panel alt text

msvcplist.jpg (250.2 kB)
avatar image 0xDEADBEEF STAFF May 06 '15 at 08:11 PM

The launcher installer installs Visual C++ redistributables for VC10, 12, and 13 using merge modules. Though I do not see any issues with the screenshot you posted I would still bet that there is some problem with the Visual C++ redistributable. I don't know how to diagnose the problem though. In the past we have had luck tracking down odd dependency issues with tools like DependencyWalker which may provide some insight here.

avatar image Neofuuma May 08 '15 at 05:58 PM

Thank you again for the reply 0xDEADBEEF. downloaded and ran dependencywalker on the Launcher.exe, and have attached. Hopefully I did this correct, and it can provide some useful informationlink text

avatar image 0xDEADBEEF STAFF May 11 '15 at 08:19 PM

So the issue is still not obvious from the Dependency Walker image that you provided but there are some clues that might lead us to a solution. Here are the bits that look interesting:


alt text


alt text


alt text

avatar image TJ V ♦♦ STAFF May 18 '15 at 05:56 PM

Hi Neofuuma,

We haven't heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you're still experiencing this issue, please respond to 0xDEADBEEF above.

Cheers,

TJ

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question