x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Unreal Editor keeps deleting my scripted actors

Hi. Problem is simple but i don't know how the hell can i solve it. I am programming using C++. After i modify any of my script .h files (example: MyActor.h) my actors stops working in editor other than it was 5 seconds before. I can modify .cpp files. I hate this Editor. It keeps deleting my scripted actors from scene. It is scheme, how i (must) do. - Modify some .h file - Check if it working - No it is not working - Reopen UE4 editor - 0 elements on scene, i scripted before.

I am trying to write bush repulsion when pawn is near but it deletes all of the bushes and erases pawn's visible element mesh data. Please help me, i can't reopen and add again 1000x bush or other actor every time i modify .h file. I forgot to mention it - after modifying .h file, when i try to select bush it selects only Instance of "Plant" (this is the name of my script) and the position is in (0,0,0) and receiving location of actor is not working in C++ code (it returns actors position, not component's position >.<)

Product Version: Not Selected
Tags:
more ▼

asked Apr 24 '15 at 02:48 PM in C++ Programming

avatar image

RazzorFlame
7 1 5 6

avatar image Matthew J Apr 24 '15 at 06:14 PM

Hi Razzorflame,

Can you provide me with either the code that you are using or a set of steps that I could follow to reproduce this issue? Also, let us know if this issue reproduces in a new project without any other additions. If we can get some good steps to reproduce this issue, we can investigate further. Let us know any additional information you can provide.

Have a nice day,

Matthew Clark

avatar image RazzorFlame Apr 25 '15 at 10:27 AM

It is link to the project: https://www.sendspace.com/file/xu3f6d It would take so much place (2GB) so i deleted few files and folders: Starter Content from Content folder Rest doesn't matter cause it was data base files from Visual Studio (pdb etc.) Try to add some members to class "Plant" or "ControlledPawn" and then compile it. You will see that grass stops repulse from pawn.

Edit: Just place one controlled pawn and few plants.

avatar image Matthew J Apr 27 '15 at 03:35 PM

Hi Razzorflame,

I took a look at your provided project and I was unable to reproduce the issue.

To be as clear as possible, I placed an instance of the class 'Plant' and 'ControlledPawn' in the scene and noticed that the 'Plant' class cannot be moved, which is to be expected as it has no transform properties set in code as 'ControlledPawn' does. I then tried adding a boolean variable and a UPROPERTY property to the plant class and both of my actors stayed in the scene. I also attempted approaching the plant class with the ControlledPawn after applying a static mesh to the Plant class and it rotated as dictated by the code.

If this issue is still persisting, or I misunderstood what you meant by 'add a member', please provide me with a list of steps to reproduce the issue, as detailed as possible. I hope that I can help you resolve this soon.

Have a nice day,

Matthew Clark

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Razzorflame,

To continue assisting you, I will need more clear steps to reproduce the issue as previously stated. For tracking purposes, I'm going to set this question to resolved. If you still require assistance, please add a comment letting me know and the question will reopen so that we can continue further.

Have a nice day,

Matthew Clark

more ▼

answered May 04 '15 at 02:42 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question