x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] Scene Capture 2D on Mobile

I have a pawn with a Scene Capture 2D component. It throws the result into a render target which is then used in a material. It all works fine on pc, even in mobile preview mode, but the material ends up black on mobile.

Am I doing something wrong? Is there a reason for it not being supported by Unreal?

Product Version: Not Selected
Tags:
more ▼

asked Apr 25 '15 at 10:06 AM in Rendering

avatar image

Roel
2.5k 70 43 143

avatar image daihao81 Aug 31 '15 at 11:47 AM

me too, do you find any solution?

avatar image rotis Oct 10 '15 at 06:45 AM

me too, but not only the scene Capture 2D. Set material to widget image on mobile has the same problem. My sony xperia sp and tablet z1 has same problem too.

avatar image AndrewHurley Oct 13 '15 at 03:13 PM

Hey guys,

I have a few questions which you can answer to help narrow down the cause of the issue.

  • Which engine version are you using?

  • What device are you deploying to? (Be specific)

  • Would you mind providing me with some screenshots of your material for your render target image?

  • Are you using translucency within your material anywhere?

Let me know if you have questions.

Thanks,

Andrew Hurley

avatar image Roel Oct 20 '15 at 08:14 AM
  • I will try it in a later version soon. Since the last time I worked on a mobile game in Unreal it was still 4.5/4.6. So it might be fixed already, can't check it right now.

  • Device: OnePlus: One A0001

  • Don't have the project laying around anymore, but the final test was a opaque unlit material with the texture directly hooked into the emissive input.

Just FYI, the cube renderer was also not working. I wanted to update it once when the game was loading to decrease downloading size of the app, but could not get it to work either.

Since the scene capture was important I did not end up using Unreal to make the project, it would be cool if I can use Unreal for my next mobile project though :)

avatar image manoelneto Nov 03 '15 at 09:47 PM

I'm having the same problem on iOS on 4.9.2. I have a SceneCapture2D attached to a camera and a UMG image that displays the capture render target through an opaque material. On PC and mobile preview everything works fine, but on iOS the SceneCapture2D result is always black.

My project uses mobile HDR off, BTW.

EDIT: The camera seems to be rendering, since the "stat initViews" data shows two views being rendered both on mobile and PC. No idea why the result is black, however. All my materials are unlit.

avatar image manoelneto Nov 03 '15 at 10:54 PM

I managed to perform a GPU frame capture on Xcode. The cause of the problem is clear: the color attachment dimensions don't match the depth attachment dimensions, resulting in an GL_INVALID_FRAMEBUFFER_OPERATION error.

It seems UE4 "recycles" the main depth buffer when updating sceneCaptures but OpenGL specifications require both color and depth/stencil buffers to have the same dimensions, which means the current SceneCapture implementation is violating OpenGL specifications. It might be that previous iOS versions ignored the error and thus it seemed to work.

BTW, there's also a crash in FOpenGLDynamicRHI::RHISetRenderTargetsAndClear() when you use SceneCapture with development or debug builds in iOS and mobile HDR off.

I'm a bit bummed that this sort of thing isn't part of automated tests.

avatar image AndrewHurley Nov 04 '15 at 04:01 PM

Hey manoelneto,

Thank you for taking the time to investigate this issue and report your findings on the potential cause. For the crash issue, could you please create a new post with some reproducible steps and as much information that you can provide so we can get a fix for that implemented?

If you need help in regards to the information we will ask for when reporting a crash, we have a helpful guide on our Forums about How to Report a Bug

In regards to the issue of the Scene Capture 2D on Mobile, it seems you have found a solution, and you sound tech savy enough to enter a Git Hub pull request for the fix. I suggest taking this route as it is usually faster to get a fix into the engine when the fix in the code is provided by the user. Let me know if you are unsure how to generate a pull request and I will provide some instructions.

Cheers,

Andrew Hurley

avatar image manoelneto Nov 04 '15 at 10:24 PM

Hi Andew,

I just managed to come with a solution for both issues, yes. I could use some help in creating pull requests. I have both changes in our company branch, but I'm not sure how to create a pull request with only those changes (github tries to push the entire branch - I'm more of a SVN person so I'm probably not using GIT as it should be used).

avatar image AndrewHurley Nov 05 '15 at 06:22 PM

I personally don't know a whole lot on generating a pull request, but I am good at finding the information on how to do so :) Use the documentation below, but let me know if you have other questions and I can direct them to someone who is a bit more experienced with generating pull requests on GitHub.

Creating a Pull Request

https://help.github.com/articles/creating-a-pull-request/

Merging a Pull Request

https://help.github.com/articles/merging-a-pull-request/

Merging Branches

https://help.github.com/desktop/guides/contributing/syncing-your-branch/

Cheers,

Andrew Hurley

avatar image manoelneto Nov 06 '15 at 11:33 PM

Thanks!

Here it is, I hope I did everything correctly:

https://github.com/EpicGames/UnrealEngine/pull/1731

avatar image Hainzgrimmer Mar 22 '16 at 03:30 PM

I'm sorry to revamp this post but I had a very similar problem and I've resolved only in part: alt text this is how I've set the material, multiplying the captured scene a lot in base color and a bit in emissive

alt text this is the appearance at first sight: a bit too dark but quite good BUT if I move myself to look outside through the mirror I'm hugely flashed alt text

I multiplyed the captured scene because otherwise it would be all black: even if I don't connect the captured scene to the emissive node and use a higher multiply on the base color I got... it's difficult to describe, imagine to add brigthness to an image in Photoshop until it's completely burnt and then make it semi-transparent on a full-black layer! but on the other hand I multiplied just a bit on the emissive and I've already got this huge flash! And I've set the bloom of the "scene capture 2d" to 0 to try to avoid the flash problem but it seems it has no effect! I'm working on a 4.10 for iOS too (iPad Pro in my case) Could this be helpful? or is it just a problem for me because the problem posted here was already fixed?

avatar image NAbreuM Jan 19 '17 at 10:22 PM

Hey, I am having this same issue. My SceneCapture2D works fine on PC but it is coming up black on my mobile Android Phones.

Is there any easy solution to this? I am willing to change engine code if anyone has super clear instructions.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Jan 20 '17 at 03:51 PM by AndrewHurley for the following reason:

The question is answered, right answer was accepted


1 answer: sort voted first

Hey Hainzgrimmer,

I appreciate the detailed explanation and screenshots you have provided. I think what could be the issue is that you aren't looking through the SceneCapture2D camera in your last screenshot, but rather the active player camera. You need to be sure to disable 'bloom' on the camera component inside of your character blueprint.

You could also add a Post Process Volume to the scene and disable bloom that way as well. Let me know if either suggestion resolved your issue, or if you need further assistance.

Cheers,

Andrew Hurley

more ▼

answered Mar 22 '16 at 09:17 PM

avatar image Hainzgrimmer Mar 23 '16 at 01:45 PM

alt text Great intuition! I disabled it from the player camera and now I'm not flashed! Now the problems are just related to the fact that the "reflect" is from a camera, so even adjusting the field of view will however be quite irrealistic, and that looking at the mirror too sided you see the mirror itself reflected or, even worse, behind the wall of the mirror! alt text

any news on make a mirror using a Box Reflection Capture with a chrome material? -big smile-

avatar image AndrewHurley Mar 23 '16 at 03:16 PM

It is all going to just take some tweaking and a bit of magic to fake the reflection. Using a real reflection on a flat surface won't produce the results you expect because reflections work best on surfaces with varying normals and roughness.

avatar image Hainzgrimmer Mar 24 '16 at 08:48 AM

"a bit of magic" uh? I'm finding hard to believe it! xD From a noob view it's kinda hard to find a realistic reflection with just the field of view to set, but I promise to continue working on it: for now it should be easier to have a realistic result without objects near the mirror or mirror surfaces too big, isn't it?

Thanks A LOT for everything Andrew! =)

avatar image AndrewHurley Mar 24 '16 at 01:48 PM

Yeah, at certain angles you will have issues. Game design is all about using the techniques you know in order to achieve the affect you are going for. Not everything is going to be realistic in terms of set up, and more often than not, you will have to find ways to fake effects.

You are quite welcome in any case :)

avatar image NAbreuM Jan 19 '17 at 10:22 PM

Hey, I am having this same issue. My SceneCapture2D works fine on PC but it is coming up black on my mobile Android Phones.

Is there any easy solution to this? I am willing to change engine code if anyone has super clear instructions.

avatar image AndrewHurley Jan 20 '17 at 03:50 PM

Could you please make a new AnswerHub post pertaining to your issue. This one was resolved and for tracking purposes we want to make sure issues do not get conflated.

Post it in either Bug Reports or Packaging and Deployment, with a description of your issue, how you reached that point, and your system specs. Once this is done, either myself or a team member will assist you.

Thank you,

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question