x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Framerate slammed when editor tooltips are shown

When playing a level in the active level editor, I've been puzzling over a strange drop in framerate from 100 fps to about 12 fps. This has been happening since 4.5 and into 4.7.6 on Win7.

As it turns out, moving the mouse over some areas of the editor UI will cause the framerate to drop. Mouse over editor whitespace areas and the framerate recovers.

Not everything in the UI causes this drop. However if you mouse over a tool / icon / asset / menu that will generate a tooltip the fps drops as the tooltip appears and will stay slow until all tooltips are destroyed.

Occasionally the fps will not recover and the problem seems to get worse as the fps declines in steps. Maybe the first 'stuck' drop is to 50 fps, the second step down puts my level at 25, the third at 18 - and so on. Restarting the game in the level editor does not fix or reverse the loss. Generally when the decrease in fps get stuck I've been running the game in a standalone viewport.

I believe what is happening when the fps decrease becomes 'permanent' is that tooltips have been displayed but not cleaned up correctly.

The way the UE4 editor and Win 7 handle mouse activity when a different application (Internet Explorer, Maya) is overlapping and in front of UE4 has always bugged me. Way too much activity on UE4 as it manages to track mouse movements even while the mouse is directly over the third party app. Essentially the mouse movements fall thru Internet Explorer while I'm here in the AnswerHub and cause the highlight to move to 'Cylinder' as pictured here. Tooltips don't generally appear until the mouse is directly over the backgrounded UE4 but they get very annoying, track the mouse, and don't play nice.

Oddly, the last two times the fps dropped to pathetic levels and got stuck the cure was the same. I simply started the Windows Task manager, looked around, made no changes, and closed it. FPS was restored as a result. Maybe this or time cleaned up a tooltip process?

![alt text][1] [1]: /storage/temp/40311-menu1.png

Product Version: Not Selected
Tags:
menu1.png (32.3 kB)
more ▼

asked Apr 26 '15 at 08:45 AM in Bug Reports

avatar image

DavidRR
54 7 15 17

avatar image Lovecraft_K ♦♦ STAFF Apr 27 '15 at 06:02 PM

Hi DavidBN -

I have been trying to replicate your experience and so far have not had the drop in FPS that you are list above. While playing in a New Editor window, I do get a minor (1 to 5 FPS drop) when I mouse over something in the editor, though that would be expected as the Slate UI is drawing the extra information from the tooltip. However, if I am playing in Standalone Game mode, I get no drop in FPS at all when I Shift F1 to regain mouse control and mouse over items in the Editor window.

If possible can you test to see if you are getting the same behavior in 1st Person Template Project or is it only a specific project.

Thank You

Eric Ketchum

avatar image DavidRR Apr 28 '15 at 02:03 AM

Hi Eric and thanks for taking a look.

It happens on a fresh 1st Person Template, fresh 3rd Person Template, the Landscape Mountains project and everything else I've tried on the Win 7 machine. I get at least a 50% fps drop with the tooltip appearing (overlapping the game viewport or not).

Machine: AMD A8-7600 Radeon R7, 10 Compute Cores at 3.10 GHz. 16 GB installed, Win 7 SP1, 64-bit OS. NVIDIA GeForce GTX 750 Ti driving a 2k monitor with latest updates.

No such slowdown on my Macbook Pro Retina but the fps normally sits at < 15 there.

David

alt text

avatar image Lovecraft_K ♦♦ STAFF Apr 28 '15 at 03:55 PM

Hi DavidBN -

You are seeing this drop when using Standalone Game instead of New Editor Viewport? Also, you have a single monitor, correct?

Thank You

Eric Ketchum

avatar image DavidRR Apr 29 '15 at 12:29 AM

Hi Eric. Yes the last third-person screen capture in my previous reply is showing the slowdown on Standalone Game Preview.

Single monitor, an Acer K272HUL at native 2560 x 1440. This is connected via DVI cable with the GTX 750 configured for Dual-Link DVI.

David

avatar image Lovecraft_K ♦♦ STAFF Apr 29 '15 at 03:13 PM

Hi DavidBN -

So far I have not been able to experience the FPS drop that you are experiencing. Can you let me know what the set resolution for your Standalone Game Viewport and are you running any VSync or Frame rate control via the Nvidia Control Panel.

Thank You

Eric Ketchum

avatar image DavidRR Apr 30 '15 at 01:46 AM

Eric,

Just to be clear, I'm not having a problem with the 'Standalone Game Viewport' that runs in a separate process. I rarely use this due to the startup time.

All my framerate trouble is in PIE and 'Play in New Editor Window' which creates a window with 'Game Preview Standalone' in the titlebar - resulting in some confusion.

That said - it doesn't matter what size the PIE viewport is set to. From 640x320 to the default 'new window' size of 1280x720 - huge slowdown of fps with tooltips.

Nvidia Controls are all on default / auto - I've done no tuning or overclocking of anything on the machine.

Regards,

David

avatar image Lovecraft_K ♦♦ STAFF Apr 30 '15 at 06:30 PM

Hi David -

Thank you for the clarification I was getting confused in my reproductions. I am going to test again and will post when I have results.

Thank You

Eric Ketchum

avatar image Lovecraft_K ♦♦ STAFF May 08 '15 at 03:40 PM

Hi David -

My apologies for the delay getting back in touch with you. Unfortunately I have not been able to reproduce the lose of FPS you are experiencing. Two questions though, are you using any driver switching software like Nvidia Optimus which switches between an integrated and non-integrated graphics cards and have you tested to see if the problem recurs in the 4.8 Preview release.

Let me know -

Thank You again for your patience -

Eric Ketchum

avatar image DavidRR May 09 '15 at 11:50 AM

Hi Eric,

Not using driver switching. The integrated graphics is disabled in bios. Previous attempts to test this problem on the integrated graphics failed as UE4 will not launch.

Just tried 4.8 Preview #1. No joy.

I've unplugged the 3DConnexion SpaceNavigator and terminated the processes. Terminated Microsoft antivirus / malware, terminated f.lux from https://justgetflux.com and several other non-essentials. I'm still getting a 100 FPS drop on the 3rd person preview (that has been converted to 4.8) when editor tooltips are shown as described in previous posts in this thread.

Screen shot provided here of the remaining processes running on the machine at the time of this last test with 4.8.

David

processes.png (91.7 kB)
avatar image Lovecraft_K ♦♦ STAFF May 12 '15 at 04:34 PM

Hey DavidBN -

Can you let me know what Driver version for your Nvidia Card you are using?

Thank You

Eric Ketchum

avatar image DavidRR May 12 '15 at 11:14 PM

NVIDIA GeForce GTX 750 Ti

Adapter RAM (2,147,483,648) bytes

Installed Drivers nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um

Driver Version 9.18.13.4752

Color Table Entries 4294967296 Resolution 2560 x 1440 x 59 hertz Bits/Pixel 32

Driver c:\windows\system32\drivers\nvlddmkm.sys (9.18.13.4752, 9.81 MB (10,284,872 bytes), 2/20/2015 1:18 AM)

avatar image Lovecraft_K ♦♦ STAFF May 22 '15 at 01:41 PM

Hi -

Sorry for the long delay, I have been trying to replicate your FPS drop on a few different machines with various Cards and Montiors. So far I have not been successful, but I have a new test for you to run which may help us narrow down the cause.

If you would, please open the third person template and confirm that you are still getting the FPS drop. Once confirmed, stop PIE and open Profiler, information about it can be found here. Then New Window PIE again (you will experience a FPS drop due to Profiler running that is to be expected), so a live Data Preview and sort by the resource consuming the most. Upload a screenshot of your test when done (you can also zip up and upload the saved Profile file as well).

Thank You

Eric Ketchum

avatar image DavidRR May 24 '15 at 06:35 AM

Hi Eric. I hope this profile file is useful since I doubt the screenshot is. I'm new to this profiler and have tried to select and show averages for a slowdown (about three are captured). File is here.

David

avatar image NeoMiles Sep 29 '15 at 11:04 PM

Hi all,

this issue is still there. I am using UE 4.9 with following specs:

5930K 32GB Ram Nvidia 980 TI 3-Way-SLI

I have constantly 120 FPS but if I hover over the UI and a tooltip shows up it drops to 5 fps. Same happens if I just go to the navigation bar. It is impossible to work with this issue - please help!

avatar image Genova Dec 17 '16 at 05:08 AM

Hello,

I'm experiencing the same problem here.

Got my new laptop: i7-6700, GeForce GTX 970M, 16go ram. And whenever I mouse over an icon and the tooltip appears, the framerate drops dramatically. UE4.14, empty project : 60fps to 30.

And my graphic drivers are up to date.

Any help would be nice. I bought that laptop exclusively to work during my "vacations" :) So that would be very depressing to have such drops.

avatar image liquidbutt Nov 23 '17 at 04:45 PM

I just had the same issue, in my case caused by Geforce experience, on Win 8.1 + gtx980. Though I have to say that on another PC with Geforce experience installed (Win 10 + gtx 1070) I don't have any issues with editor at all.

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

This problem with framerate & tooltips disappeared from my dev machine a few days ago.

Wiped my machine, installed Windows 10, and reinstalled UE 4.9. I had been on Win7 with Nvidia, ASRock, and AMD drivers and utilities installed. Windows 10 has much better support for the hardware and UE4 seems to run well on it.

David

more ▼

answered Oct 19 '15 at 05:04 AM

avatar image

DavidRR
54 7 15 17

avatar image Allar May 28 '16 at 04:27 PM

Out of no where this is affecting me too. No recent changes, software or hardware. Running on a ridiculously overspec'd rig, Windows 10, 2x980Ti...

Affects all engine versions I load. Don't know what is going on, only reference to what is happening here is this answerhub thread.

avatar image Markus Maximus Jul 01 '16 at 07:14 AM

For people with AMD cards and Catalyst Control Center installed, setting the 'Texture Filtering Quality' to performance preset seems to improve things. Additionally, setting the 'Surface Format Optimization' to Off seems to remove this lag all together.

If there's such a setting in Nvidia control panel. it might be worth giving this workaround a try.

EDIT: Just an update: with the above workaround, you'll see a massive drop in performance in Unreal and 3ds Max if both are running at the same time.

EDIT 2: Also, having the Catalyst Control Center running in its separate window simultaneously with UE4 or 3ds Max also causes a performance hit. Either minimise it to tray or exit the application if it is not needed in the background.

(comments are locked)
10|2000 characters needed characters left

Eric, This FPS tooltip bug on my machine might develop into a feature request - it can be very useful.

I didn't appreciate that I had my 'rate of turn' for the character nav linked to frame rate - until I moved the project to my MacBook Pro. It takes a few minutes to copy the project to the MacBook so I was looking for a way to reduce the framerate of the game in PIE on the PC.

Using a project setting of 'Fixed Frame Rate' or setting the max smoothed frame rate - I can't get the frame rate to drop below 60 in PIE. But the tool tip bug gets me down to about 17 fps which is nearly perfect for emulating the speed on the MacBook.

So that has me wishing for three or four toolbar buttons that I can press or hover over during PIE - to instantly switch the actual FPS of the game to 15, 25, 40, and 60 fps for example.

David

more ▼

answered May 27 '15 at 05:04 AM

avatar image

DavidRR
54 7 15 17

avatar image Lovecraft_K ♦♦ STAFF May 27 '15 at 03:00 PM

Hi David -

Feature Request is not a problem, I have entered it as UE-16201 and will keep you informed here as our engineers investigate the possibility of adding it into the engine. I am going to mark the issue resolved here, but we will continue attempting to reproduce the issue or if you have any new information please feel free to post back here.

Thank You for your patience -

Eric Ketchum

(comments are locked)
10|2000 characters needed characters left
more ▼

answered Dec 18 '17 at 07:56 PM

avatar image

Plzaxbb
1 1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question