Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Unable to start program UE4.exe error

When I hit ctrl+F5 in MSVS 2013 I get the error

Unable to start program 'G:\Program Files\Epic Games\4.7\Engine\Intermediate\Build\Unused\UE4.exe'. Which makes sense since that path doesn't exist. But how do I correct MSVS to use the correct path? Also, what is the correct executable to use? Because there is no UE4.exe in my UE4 install directory. Is this supposed to be the UnrealEngineLauncher or EpicGamesLauncher?

Product Version: Not Selected
more ▼

asked Apr 26 '15 at 08:34 PM in C++ Programming

avatar image

78 8 9 17

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

I actually had a similar issue.

To fix the issue, you have to right click the game solution from your solution explorer and select the option "Set as StartUp Project" and that should highlight the game solution. Cntrl-F5 will then work.

more ▼

answered Sep 23 '15 at 04:43 PM

avatar image

578 17 79 89

avatar image Azarus Sep 25 '15 at 12:44 PM

Clever! Thank you! :-)

avatar image damanDLI Mar 27 '17 at 04:24 PM

Thanks, that was easy :))

avatar image Burnes06 Oct 07 '17 at 05:21 PM

Thank you! :D

avatar image YuchenMei Jan 23 '19 at 10:16 AM

Thanks It worked for me. I got this error after manually deleting my intermediate folder.

avatar image Erling Mar 26 '19 at 01:32 AM

Thanks for posting this solution. I was trying out different editors to see which I preferred (Visual Studio community 2017 vs Visual Studio Code vs CLion) and through it all when I came back to VS2017 I had the same "Unable to start program..." message. I noticed the compile times were almost nothing, which I knew was wrong but due to my lack of experience with VS I didn't know why. Through it all someplace along the way the UE4 project was bolded and set as the StartUp Project in the Solution Explorer. Your fix got me back on track!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I found out I had to delete the .suo file in my project directory.

more ▼

answered Apr 27 '15 at 01:02 AM

avatar image

78 8 9 17

avatar image Azarus Sep 23 '15 at 03:07 PM

If the file is hidden then use batch: del /S /F /AH *.suo

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

For me the solutions above didn't help. In the "Set Startup Project" option I had to set the radio button to "Multiple startup projects" and change the order of projects so that ue4 project is above my own project. Now set the action for both projects to "start". As described above in order to access this menu, you have to right click your solution within visual studio and then select the option "Set Startup Project".

However I still get the error that the ue4.exe could not be found. But still the engine launches and I can debug the project.

Hope that helps anyone with the same issue.


more ▼

answered May 28 '17 at 04:27 PM

avatar image

169 13 15 26

avatar image TobiGroth Sep 26 '18 at 09:24 AM

same here, but when I set Project to 'Start' and theUE4 to 'None' it worked perfectly without the error message.

...wondering what caused this in the first place

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question