x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.7.6] 3DS FBX export: TurboSmooth and smoothing groups lost in UE4

Hi there,

I have a large car model in 3DS Max 2015 with subdivision surfaces (TurboSmooth). The model consists of about 50 different meshes which are packed in several groups:

alt text

The whole model of the car has about 1.2 Mio Polys (after TurboSmooth was applied). The most parts have "iterations" for TS set to 1, some other parts to 2.

alt text

As you can see, smoothing groups are also used (shaded view, ignore the blurry preview texture):

alt text

These are the 3DS export settings I use:

alt text

After the import in UE4, the mesh looks like this (wireframe):

alt text

It looks like TurboSmooth process didn't happen at all, the polygon count is the same as before. Also the smoothing groups didn't make it to UE4 as everything looks very blocky:

The static mesh editor also gives these numbers:

alt text

(Same number of polygons as before).

I have to say that I'm still not very experienced in 3DS Max, so maybe this is a simple misconfiguration? Did anyone have the same problem?

What could be the problem here? Did I something wrong?

Product Version: Not Selected
Tags:
more ▼

asked Apr 27 '15 at 04:41 PM in Using UE4

avatar image

spyro
1.7k 104 116 228

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Spyro,

If you have "Turbosmooth" checked this will keep the modifier from being collapsed to your mesh in the FBX. This will allow the modifier to still be accessible if you import it into another scene in Max or Maya for instance.

If you uncheck this, it will be collapsed and you will not have access to undo the turbosmooth if you import into another Max or Maya scene.

So, you can collapse this down before exporting or you can just choose to uncheck that option and it will collapse it down for the FBX that is imported into UE4.

The smoothing groups not being there is probably because they're not properly setup on the base mesh that has not used turbo smooth.

Let me know if that helps,

Tim

more ▼

answered Apr 27 '15 at 09:13 PM

avatar image

Tim Hobson ♦♦ STAFF
49k 886 98 874

avatar image spyro Apr 27 '15 at 10:15 PM

Hi Tim,

many thanks, I really got this one wrong. Tried it as you suggested and 5 minutes later the model was working in UE4 :)

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question