x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Problems After Package on another system. Help?

New to unreal 4 so bear with me please. This is university work so please help. Anyway, after building my scene and everything (for presentation and such) I package it onto my desktop. open it and check on it, everything's fine and as it should be (below, the good one). Try to run the application on another computer both my laptop and those computers at University and the lighting is messed up big time. You can't see anything and everything remains dark. you can see the flashlight, but that's about it. (below, the bad one). Help please! I have no idea what's causing it. At first I thought it might be the engine scalability, but they're all set to epic and my computer has changed them. My teacher thought it was something with my computers Colour profiles, but they were on the default setting. Really need to get this fixed as I have to submit it by the end of May. Help? Please? alt text (bad one, ignore the lightning needs to be built. I know for a fact that isn't whats causing it. :/) alt text This its what its supposed to look like. Its the exact same file and exact same positioning, but for some reason, either during or after the packaging process, the lighting mucks up. The skybox doesn't even load in the bad one. I really don't know what to do. Help? please.

Product Version: Not Selected
Tags:
bad.jpg (68.7 kB)
good.jpg (413.1 kB)
more ▼

asked Apr 27 '15 at 06:01 PM in Packaging & Deployment

avatar image

Joetee
1 1 4 7

avatar image Samantha Sutton ♦♦ STAFF Apr 27 '15 at 06:36 PM

Hey Joe,

How significant is the difference between each computers specifications? Also, have you tried building both projects on each machine before packaging? Also, are you able to build and package your project on the machine that seems to be working correctly, and send the packaged file to your other computer? If you can send the packaged project to the other computer that's having trouble, does it open up correctly?

Looking forward to hearing from you!

avatar image Joetee Apr 27 '15 at 07:10 PM

I wouldn't say they'e massively set apart from each other, Its hard to judge because these computers are at university. I have been testing it on my laptop with the same outcome, (naturally, my laptop was as laggy as hell but the outcome was the same.) I can't work on any of the university systems well either because they don't have unreal 4 yet. What I've been doing is packaging at home the program, copying that package folder onto my memory stick and been using that on the other systems. I tried to package it without light maps on on a whim just to see if that changed anything, but there wasn't any change. Would it just be my computer that's messing it up?

avatar image Joetee Apr 27 '15 at 07:18 PM

Lightmaps off rather. Not on. No change.

avatar image Samantha Sutton ♦♦ STAFF Apr 27 '15 at 08:14 PM

Hey Joe,

Are you able to get the system specifications off of all three computers? There could be an issue with the graphics card or RAM differences, since you're packaging your project at home and moving it on a flash-drive.

You're also more than welcome to provide me with a link to download the project, just make sure you send it to me through the private messages in the forums so no one else has access to your project. I'd be more than happy to see if the packaged result looks the same or not.

Thanks!

avatar image Joetee Apr 27 '15 at 08:41 PM

The specs of my home computer (the one I've built it on) and my laptop are as follows. Theres probably going to be a big gap between my laptop and my computer anyway coz its a bit old and not a particularly good laptop. As for the specs at Uni, they might be harder to get. Home: Processor: Intel(R) Core(TM) i5-2500K CPU @ 3.30GHz (4 CPUs), ~3.3GHz Memory: 4096MB RAM Available OS Memory: 4078MB RAM Card name: AMD Radeon HD 6700 Series Chip type: AMD Radeon Graphics Processor (0x68BA) Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601)

Laptop:
Processor: Intel(R) Core(TM) i5-2450M CPU@ 2.50GHz (4CPUs), ~2.5GHz Memory:: 4096MB RAM Available OS Memory: 4008MB RAM Card name: Intel (R) HD Graphics Family Chip Type: Intel (R) HD Graphics Family Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601)

My mate is installing Unreal4 on his computer and I'm going to move the files and package it on his computer to see if its my machine or my engine what's causing it. Just to test. If it doesn't change, then i'll PM you my work.

avatar image Samantha Sutton ♦♦ STAFF Apr 27 '15 at 09:29 PM

Hey Joe,

Sounds perfect. Just keep me updated on what you're working on, so we can get to the bottom of this issue.

Cheers!

avatar image Joetee Apr 28 '15 at 05:05 PM

Okay, so we kind of fixed it. My mate installed Unreal 4 on his system, I brought the package and it worked fine, so we figured it must only work on systems with Unreal 4 Installed. At this point, I'm not sure if its a bug with the engine or a bug with the my game in particular since no-one else it seems to be having this problem. If you still want me to send you the files then I will. Joe

avatar image Samantha Sutton ♦♦ STAFF Apr 28 '15 at 05:16 PM

Hey Joe,

When you pulled up the projects on the computers at University, did you only bring the .uproject with you or did you actually package the whole project? Because if you've packaged that project, it would be an executable, which should still work on a computer without UE4.

Thanks!

avatar image Joetee Apr 28 '15 at 05:29 PM

Yep, brought the whole Package. As the image shows, the actual game loads up fine, but the lighting never seemed to work; the sky box didn't seem to load nor the directional Light or skylight. the only lights that seemed to semi- work was the flashlight and point lights. Joe

avatar image Samantha Sutton ♦♦ STAFF Apr 28 '15 at 08:23 PM

Hey Joe,

Are you packaging only for Development? If you're not sure, go to File and select Package Project, Build Configuration and then select Shipping. Once you've selected Shipping as your build configuration, you'll be able to open that executable on any system, which then you shouldn't run into this issue.

However, if you're already building for shipping, please let us know exactly how you're setting your project up for cooking and packaging.

Looking forward to hearing back from you! :)

avatar image Joetee Apr 29 '15 at 07:41 PM

Heya, me again. Tried 'shipping' this time and still no change. The only other thing I checked which might be causing issues (after looking around) were the engine scalability settings, and I thought mine might of been changed, but they were still all at the 'epic' setting anyway, so I thought on the off chance my computer was somehow better at the ones at Uni, I set the settings down to they're lowest setting, and STILL no change. The rest of the packaging settings I haven't changed really and are most likely still on their default settings. University has decided after seeing me stressing to get Unreal 4 installed on their system, so at the very least, it SHOULD work there (I'm hoping to god that it does.) Still I have no idea what else could be causing it. Any ideas? Joe.

avatar image Samantha Sutton ♦♦ STAFF Apr 30 '15 at 02:23 PM

Joe,

Could you please build the lighting on your project, package it for development and shipping, and then try to run the projects on the computers at University? I'd like to see if there is any difference at all.

Could you please also include your build logs?

Thank you!

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey Joe,

I haven't heard from you in quite a few days. For tracking purposes, I must close this thread at this time. However, if you're still experiencing trouble with this specific topic, please do not hesitate to reply back to this thread and we will assist you further.

Have a great day! :)

more ▼

answered May 04 '15 at 02:31 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question