x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Disabling static lighting on terrain

We have a very large world that has a mix of interiors and exteriors of buildings and we would like to have static/stationary lighting for the interiors, and dynamic lighting for the exterior. I ran into a problem when building light though, that even with lightmass importance volume, the lighting gets baked into the landscape as well, and from what you can imagine isnt what we would like. So is there anyway to disable static lighting on the terrain to prevent massive compile times and larger ram usage for lightmaps?

Product Version: Not Selected
Tags:
more ▼

asked Apr 28 '15 at 01:08 AM in Using UE4

avatar image

Shirk
245 41 52 64

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi Shirk,

While it is possible to stop an object from casting a static shadow, you cannot stop an object from receiving a static shadow unless it is movable since there will be no need for baked lighting. All Static objects use a lightmap that handles the static shadows that are baked in.

There are a couple of ways to try to get around this though:

  • For your Landscape, you can adjust the Static Lighting LOD to 1 or 2 to prevent the landscape bake from crashing lightmass or running out of ram.

  • You can disable "Cast Static Shadows" for any meshes that are not needed to be baked.

more ▼

answered Apr 28 '15 at 02:46 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 887 101 878

avatar image Shirk Apr 28 '15 at 06:04 PM

Thanks for the reply, but neither of these options really solve my problem.

avatar image Lord Pol Nov 20 '16 at 03:06 PM

Same problem Here.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Shirk, we have the same problem on our open world too, and the solution I used is a level based static lighting world. I keep the landscape in tiles with world composition, and I create a level for every static lighting based environment, then I build them without having the landscape loaded. To do this you'll need to keep landscape out of this levels, so for example you won't use it for floors or walls.

more ▼

answered Apr 10 '17 at 09:32 AM

avatar image

Iacopo Antonelli
8 3 6 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question