x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Reset level with oculus

Hi !

I have an app that uses sublevels (I have the persistent level with my character and all my usual blueprints, and one sublevel with all the models the artists give me, so i can use my "code" on many projects and juste add new content as a sublevel).

As we must make this app compatible with the oculus rift, i'm not using any gui. Everything works as expected, until we try to reset the levels. Basically, i have a keyboard event en level blueprint that trigger a full reload so we can get our app at its starting state.

It's perfect when using the app without the oculus, but if the oculus is plugged, then the app crashes. :(

What i tried :

  • Reload the level with an "Open level" node. With or without the "absolute" parameter.

  • Reload the level with the "Execute console command" node and "RestartLevel" command.

  • Looped on widgets of class and remove them before reloading, just to be sure, as suggested in another post.

  • Packaged in Shipping 32bits and Develoments 64bits.

When i try it in the editor (even with the "VRPreview" play mode, it works fine too. It's just with the packaged version.

I have Unreal 4.7.6 and use DK2 on runtime 0.5.0.1-beta.

Any idea what's going wrong ? Did anyone had a similar problem ?

EDIT : Found the dump file of the error and it says : Exception code : 0xC0000005 Exception Information : This thread tried to read from or write to a virtual address for which it does not have the appropriate access.

Product Version: Not Selected
Tags:
more ▼

asked Apr 28 '15 at 08:53 AM in Bug Reports

avatar image

Aiko Creative Vision
85 5 6 10

avatar image Aiko Creative Vision Apr 28 '15 at 09:31 AM

Cloned the project and removed the sublevel with all the models, just keeping my character, BP, etc...

Trying to package it in shipping 32bits and it works ! o_O

I also tried to take my persistent level and add it a tiny sublevel with basic shapes, and it works too.

So i guess it's not my code that is in fault, and that there is something in the sublevel models that don't like to be reset when using the oculus, but what ?

This sublevel also holds light effects and stuff like that.

avatar image Rudy Q ♦♦ STAFF Apr 29 '15 at 03:31 PM

Hello Aiko Creative Vision,

I was unable to reproduce this issue on our end. I have a few questions that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Could you provide a detailed list of steps to reproduce this issue on our end? (I would like to make sure that we are following the exact same steps)

  2. Could you provide screen shots of any blueprints that may be involved with this issue?

  3. Could you provide any code changes that you have made that may be causing this issue?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Aiko Creative Vision,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

more ▼

answered May 04 '15 at 02:53 PM

avatar image

Rudy Q ♦♦ STAFF
47.4k 545 132 524

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question