x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.7.6] blueprint text search skips interface implementations

Build: 4.7.6, built from source

Description: The text/reference search does not turn up any results from inside a blueprint interface implementation. Probably the same issue as this - but still present in 4.7.6

Repro Steps:
1. implement an interface function (not an interface event)
2. search for anything mentioned in that function implementation

alt text

Product Version: Not Selected
Tags:
more ▼

asked Apr 28 '15 at 02:39 PM in Bug Reports

avatar image

VictorC
11 2 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey Omichron,

I located the Jira where this was resolved, which is UE-3665 however, I also located a feature request that requests that searching blueprint filters for calls to specific classes, which is UE-19444. I also located another Jira report which is UEBP-90 where it's stated that "Find Results" in blueprints do not return variables inside an interface function. So this does look like it's happening, I'm not quite sure why it located both of mine. Perhaps it was because I used different phrases.

Feel free to check back on these in the future and I'll be more than happy to assist you further. Have a great weekend!

more ▼

answered Sep 04 '15 at 10:17 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey VictorC,

Thank you for noticing this issue within the Editor. I was able to reproduce this issue and I have verified that it's already in Jira. Our developers did fix it for 4.8. I'm not sure whether or not it'll be released with the original release of 4.8, but it should be implemented within 4.8 in the future.

If you have any further questions, please do not hesitate to let us know. Cheers! :)

more ▼

answered Apr 28 '15 at 05:19 PM

avatar image Omichron Sep 01 '15 at 11:45 PM

This appears to still be broken in 4.9.

avatar image Samantha Sutton ♦♦ STAFF Sep 02 '15 at 05:44 PM

Hey Omichron,

I have tested this in 4.9 and I have gotten the 'Find Me' search to work. Could you please explain what's going on further in your case?

Thank you!

avatar image Omichron Sep 02 '15 at 06:39 PM

The same steps and behavior as above, except that I'm not building 4.9 from source but testing with the downloaded one from today.

Here is an example. I create a SearchInterface with just one function (and to make sure that it's not an event, it returns a boolean), called HelloWorld. The class that implements it contains a GlobalSearchable boolean for testing, and its implementation of HelloWorld has a local varibable, LocalSearchable and a PrintString.

Searching (with Find in Current Blueprint Only UNCHECKED):

  • Searchable - Doesn't find LocalSearchable, only gives me the GlobalSearchable, and doesn't give me any references that might be used inside the interface implementation

  • FooBar - Doesn't find the PrintString inside HelloWorld, even though it will find it in PrintStrings outside, in the class' EventGraph

  • HelloWorld - Finds the SearchInterface function definition, does not find the actual implementation

alt text

avatar image Samantha Sutton ♦♦ STAFF Sep 03 '15 at 07:17 PM

Hey,

I have been able to locate mine without any trouble. Have you tried searching for 'LocalSearchable'? Perhaps the engine can't read words that are connected, which is a possibility.

Let us know!

avatar image Omichron Sep 04 '15 at 05:44 PM

No, I have tried substrings and exact matches, to no avail. I have tried function names, local variable names, external variables being used in the function implementations, parameters, etc. I'm attaching a sample project that displays the issue on multiple machines/setups.

Searching for 'lucky' will only return results from the EventGraph but will not return anything inside the interface implementation on "GetLucky" or "GetUnlucky".

This is all I get: Find Results for 'lucky' not returning values inside of interface function definition

Do you get different results than that?

Do you happen to know what github commit was supposed to have fixed this? I can try to track this bug down in code in case there's a flow that would bypass the fix.

sample project

searchissue.zip (17.1 kB)
searchlucky.png (328.4 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question