x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How do I fix the, "Lighting Needs to be Rebuilt" Error?

I'm using UE4 on a mac and so far have completed of the first Level building tutorials. I've saved out my project and my level and each time I come back in I have an error at the top of my viewport.

The error reads: "LIGHTING NEEDS TO BE REBUILT (34 unbuilt object(s))"

Additionally, the atmospheric fog is no longer showing in editor as well. This could be a separate issue.

When I look at the items on my list, There are items listed with yellow or orange exclamation marks next to them. Can someone please point me in the right direction on how to fix these errors as I think that they might be related to the above mentioned.

Product Version: Not Selected
Tags:
more ▼

asked Mar 31 '14 at 03:06 AM in Rendering

avatar image

broopanda
73 3 6 8

avatar image xxxAriOrHxxx May 30 '18 at 02:52 PM

We have the same problems and know what causing it. We have small objects setup Lightmap Type - Force Volumetric. This objects are causing editor constantly tells us that this objects has to be rebuild right after light calculations. Any ideas how to resolve it? Thank you!

avatar image Ivángarcia96 Apr 26 '19 at 07:46 PM

I found that inside version 4.22 in the main tab under "Design" underneath it, by pressing "Design only lighting" you have to install "SwarmAgent" to fix it

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

8 answers: sort voted first

To rebuild lighting hit the drop down arrow next to "Build" in the main toolbar and select "Build Lighting Only." Alternatively you can just hit the "Build" button on the main toolbar.

I just found this about the exclamation marks in the scene outliner: https://docs.unrealengine.com/latest/INT/Engine/UI/LevelEditor/SceneOutliner/Interface/index.html

The exclamation marks are indicators of the mobility type of the actors.

If the fog isn't showing I would recommend clicking on it in the scene outliner and then in the "Details" panel under the "Rendering" section make sure the checkbox next to "Visible" is checked.

more ▼

answered Mar 31 '14 at 03:16 AM

avatar image

Apoc
413 10 12 55

avatar image AClark May 14 '14 at 09:01 PM

For some reason whenever I mess with objects that allow light to enter the room I receive the same error. I did what you suggested and that seems to help for the most part, but is there something that I am doing wrong to cause this error? Also when I rebuild, any surface that would not have a significant amount of light hitting it becomes pitch black will not illuminate if a new light source is made. Thanks!

avatar image Adnoh Jan 12 '17 at 11:01 AM

set your lighting to "mobile" while developing - so it is calculated in realtime. When youre done, you can switch back to static for example

avatar image Intervence Jun 23 '17 at 03:39 PM

Thanks alot helped me alot. That was a annjoying error messages that appears all the time. When we are in developing mode it's should have been done automatic... i was about too quit yesterday.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

You have to rebuild lighting after modifying the scene, that's what the warning is telling you. You can make many edits and then rebuild once though to be fast.

more ▼

answered May 15 '14 at 07:52 PM

avatar image

DanielW STAFF
1.9k 31 11 72

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

World Settings -> Force No-Precomputed Lighting = True (It is a checkbox, so check it)

more ▼

answered Dec 12 '16 at 08:50 PM

avatar image

Midsoft Games
56 1 3 11

avatar image f-WARL0CK-m Dec 28 '17 at 07:11 PM

Thanks that helping me a lot ^^.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi guys when i rebuild lighting i get an an error saying actor lightmap resolution too large could rebuild light is there a fix please help.

more ▼

answered Dec 28 '17 at 08:04 AM

avatar image

Whisper92
6 1

avatar image APOCRS1980 Feb 13 '18 at 06:52 AM

I'm having the same issue, I have set the light map density resolution on the objects from 64 to 2 and even though they are now green in debug with some of the lower parts tinging into the orange I'm still getting errors when trying to rebuild the lighting. Highly frustrating!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi!

I think before talking about errors and bugs you should understand the lighting in Unreal! You should understand what is static and dynamic lighting to decide which one you need for your scene before completely turning off light calculation as a solution! :S I advise you to go through this page to clear things out: https://wiki.unrealengine.com/LightingTroubleshootingGuide

But basically as it was said before a couple of times: if you use static(or stationary) lights your lighting information will be baked into your (static)meshes! Will take just one calculation (BUILDING LIGHTING) and after that it's on your meshes like a "material". And because it's baked into your meshes whenever you make changes like moving meshes or placing new ones or changing your light properties: you will have to rebuild your lights because there are new information and your scene needs to be "updated". Keep in mind that this is the only way right now to get proper GI! You won't get any from dynamic lighting!! I hope it clears a few things but read through that wiki page also!! Good luck!

more ▼

answered Feb 13 '18 at 03:29 PM

avatar image

Makigirl
1.3k 4 4 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

My friend did you find the answer for your issue? Am having the same problem here and am tired searching the web

more ▼

answered Jan 07 '17 at 08:11 PM

avatar image

Polaris
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Just press the 'Build' button whenever you see 'needs to be rebuild'

more ▼

answered May 28 '17 at 08:37 PM

avatar image

TheRift
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

First of all in UE4.17 i think its called Pre-compute Visibility Which will increase Run-time memory. And increase lightning build times. I cant find force no computed lightning. also precompute visibility is by default disabled. to solve the rebuild lightning error You have to BUILD.

more ▼

answered Sep 11 '17 at 01:15 PM

avatar image

SupDeity
468 4 6 15

avatar image xxxAriOrHxxx May 30 '18 at 02:53 PM

We have the same problems and know what causing it. We have small objects setup Lightmap Type - Force Volumetric. This objects are causing editor constantly tells us that this objects has to be rebuild right after light calculations. Any ideas how to resolve it? Thank you!

avatar image hamtaro1H Aug 11 '18 at 03:37 AM

@Jurassic Studios - The "Force No Precomputed Lighting" option is still in UE 4.17 and higher - just keyword "Force" into the World Settings search bar.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question