x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Android] AssetRegistry not working

Hello ! When using the AssetRegsitry with the Android PIE, it isn't working. When using classic (i.e. windows) PIE, it works. I need it for finding maps and textures at runtime. Here is my code (working on windows PIE):

 bool AMainMenuGameMode::IsValidMap(FString Path)
 {
     FAssetRegistryModule& AssetRegistryModule = FModuleManager::LoadModuleChecked<FAssetRegistryModule>("AssetRegistry"); // Initial AssetRegistryModule
     TArray<FAssetData> AssetData; // Found assets Array declaration
     FARFilter Filter; // Assets search filter declaration
     Filter.ClassNames.Add(FName(*UWorld::StaticClass()->GetName())); // Search only for maps...
     Filter.PackagePaths.Add("/Game/Maps"); //...only in the Maps folder
     AssetRegistryModule.Get().GetAssets(Filter, AssetData); // Perform the search
 
     UE_LOG(MenuGMLog, Log, TEXT("Assets found count : %d"), AssetData.Num());
 
     for (auto it : AssetData) // For each found map...
         if (it.PackageName.ToString() == Path) //...if the map's path is equal to the path passed in parameter...
             return true; //...return true to notify this.
 
     return false; // But if no path corresponds to the parameter, return false.
 }

It logs Assets found count : 0, and returns false even if the path exists Is it a bug, or a mistake from me? (Using UE4.7.6 built from github)

PS: Sorry for my bad english

Product Version: Not Selected
Tags:
more ▼

asked Apr 29 '15 at 11:35 AM in C++ Programming

avatar image

Evols
114 12 11 16

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

any one knows??

more ▼

answered Feb 23 '18 at 07:38 AM

avatar image

jackey7
8 3 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question