x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

C++ Classes don't show in Editor

Hi,

I normally build my Editor in Debugmode via Visual Studio. Everything works fine, but when I add C++ classes while in Debug Editor and later use the Editor normally via the Epic Launcher or by clicking the .uproject file in my Project, the Editor does not recognize those Classes I added in Debugmode. Is there a chance to get this fixed?

greetings

Product Version: Not Selected
Tags:
more ▼

asked Apr 29 '15 at 02:13 PM in C++ Programming

avatar image

dlay
3 2 2 3

avatar image dlay Apr 29 '15 at 02:31 PM

Ok after deleting some of my Intermediate and Saved files in the project and rebuilding everything from scratch the Editor finally got it. But I dont want to do this every time I add classes in Debug...

avatar image Matthew J Apr 29 '15 at 02:41 PM

Hi dlay,

I looked at your process and tried to reproduce this issue but I am still able to see my classes.

To explain my process; I downloaded the 4.7.6 source from github and ran the Setup.bat, GeneratedProjectFiles.bat and then the .sln to build the engine's source. I then launched the editor in debug by setting UE4 as a startup program and hit F5. After this I created a new C++ project with basic code and starter content. I then created a new C++ class of the Pawn class. I saved my new class and my project files and then closed the editor. I opened the editor normally via the Epic Games Launcher and chose that same project. It asked if I wanted to open a copy as it saw it as being associated with a different version so I opened a copy. I was then able to see my classes after loading the project.

If there are any steps I missed or something you did differently, please let me know so that I can try to reproduce the issue you're experiencing.

-Matthew Clark

avatar image Ant0nin Jan 30 '16 at 10:40 AM

I have the same problem. I followed the process but it still doesn't work and I don't know why. Please help !

avatar image Matthew J Feb 01 '16 at 07:20 PM

Hello Ant0nin,

Did you try the solution posted by Jamie Dale below? That seems to be what helped the previous user.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first
more ▼

answered Apr 29 '15 at 02:57 PM

avatar image

Jamie Dale STAFF
7.5k 177 67 307

avatar image dlay Apr 29 '15 at 03:32 PM

Yes, it seems Development Editor and DebugGame Editor are not onpar. c++ classes I add in DebugGame Editor don't show up in Development Editor directly. Should I change my workflow to only add c++ classes in the Development Editor (which I could build from VS as well), to prevent those problems?

avatar image Jamie Dale STAFF Apr 29 '15 at 03:37 PM

It's fine to use "DebugGame Editor" through Visual Studio, however you must remember to build "Development Editor" before you can open your project from the launcher again.

If you were to always start the editor via Visual Studio then this wouldn't be an issue, but if you want to mix and match then I'll leave the decision to you about whether to always use "Development Editor" or not :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question