x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

"Root Motion From Everything" Not Working

I'm working in UE 4.7.6, and I'm having trouble using Root Motion From Everything in the defaults of my Animation Blueprint. I'm trying to do a similar animation setup to this: https://www.youtube.com/watch?v=bUQ83Szuh7E

The problem is, when I turn on "Root Motion from Everything", the character will not respond to the movement direction keys. With "Root Motion From Everything" off, the character does move with the movement keys. All animations used are root motion animations with root motion checked for each. I'm using the Rifle Animset Pro from the marketplace.

alt text

I feel like I'm missing a simple step, just not sure what it is.

Thanks

Product Version: Not Selected
Tags:
ue-locomotion.jpg (321.2 kB)
more ▼

asked May 01 '15 at 02:32 AM in Blueprint Scripting

avatar image

Snipe3000
74 20 21 24

avatar image Steve Hardister ♦♦ STAFF Jul 02 '15 at 02:55 PM

Hey Snipe3000,

Check out this thread: [link text][1] [1]: https://answers.unrealengine.com/questions/187452/how-do-i-enable-root-motion-in-47.html

One thing that stands out is "Just to make sure - you;ve set Root Motion from Everything in the defaults section, not the preview one, right?" -This fixed another user's problem. -plus they discuss some other possibilities.

If you cannot find the fix to your specific issue there, let me know and we'll look at this further.

Thanks!

avatar image Snipe3000 Jul 04 '15 at 04:27 AM

The settings you mentions are set correctly. I think the issue is how I'm trying to start the animation system. I'm trying to use root animation for movement, but I'm using the characters speed (AddMovementInput) to try to start the animation. Setting Root Motion from everything turns off AddMovementInput so the character no longer has speed.

Should I use Montage Play instead?

avatar image Steve Hardister ♦♦ STAFF Jul 06 '15 at 07:58 PM

Hi Snipe3000,

Would you be able to send your files via dropbox so I could take a closer look?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Snipe3000,

Were you able to resolve the issue of your character not moving with the movement keys when you are using Root Motion? If not, if you can provide your files I'll be happy to take a look and see if I can find out the cause.

Otherwise, I'll be marking this as resolved for tracking purposes. If you'd like any further help with this issue you can reopen this post by responding any time.

Thanks

more ▼

answered Jul 14 '15 at 09:14 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question