x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Lighting Issues When Transferring from PC to Mac

Hello there,

I'm currently working on a project on both a Mac and PC, transferring the project manually when necessary. The transfer goes smoothly, with all assets and materials generated properly, but I'm having an issue with lighting. I created the lighting on the PC, and it looks great. Then I transfer the whole project over to the Mac, and the lighting in many of the locations is significantly darker than it appears on the Windows version. I checked the light values, and they're consistent across the platforms.

Is this a known issue? I could certainly attempt to tweak the lights manually on the Mac to get the desired brightness, but this would cause issues when I transfer back the the Windows.

Any advice for getting consistent lighting?

See the images below for comparison. alt text

This is an image from the PC

alt text

This is the same room, same materials, and same lighting on the Mac.

Product Version: Not Selected
Tags:
more ▼

asked May 01 '15 at 03:05 AM in Everything Else

avatar image

bnisbet
33 11 17 20

avatar image BenjvC Sep 30 '15 at 05:05 PM

I'm seeing the same behavior here, identical difference in intensity between Mac and PC, regardless of which end is first to generate the scene. I see I'm the first to answer to your issue from back in April. Were you ever able to resolve the problem? If so, thanks for sharing

avatar image dorianv Oct 15 '15 at 09:53 PM

Same issues here.

avatar image Rankopfpro Nov 08 '15 at 06:20 AM

Also experiencing this issue. Doing a game jam and team mates on PC have no issues with Lighting. I on the other hand have this issue on Mac. We encounter this on our project last year and had no solution. Two different game, different versions on the engine and even different Macs.

Currently on OS X 10.11.1 and UE 4.9.2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

My issues have cleared in the meanwhile. I'm thinking this related to various platforms working off a cloud and opening into different engines. Once we all got on the same page with the same engine, synced to the same project file, the problem went away. Can't be certain it's that simple, but possibly is.

more ▼

answered Nov 08 '15 at 05:00 PM

avatar image

BenjvC
70 3 9 12

avatar image Rankopfpro Nov 08 '15 at 08:35 PM

We are all on UE4.9.2 and using Perforce to sync,

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Sorry for the late response.

To remedy this, I had to adjust the lighting intensities and values manually on the Mac version to match the appearance of the PC version. Unfortunately, I wasn't able to find anything that was more efficient than this.

more ▼

answered Nov 08 '15 at 06:48 PM

avatar image

bnisbet
33 11 17 20

avatar image Rankopfpro Nov 08 '15 at 08:36 PM

Thanks, but not sure if I can do something like that now.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Ok After digging around to answer this question for myself I found out the issue is caused by OpenGL and therefore Mac not supporting Eye Adaption. So on PC, if the lighting is too dark they camera adapts to bring up the exposure, on the Mac, it just stays dark.

So the solution is to adjust the lighting to be more intense, like has been posted here. If you want to disable this feature on the PC version so you can match the lighting between both builds, you need to disable it for each camera, including the player camera included in your blueprints. Once you select the camera, in the details window go to Camera Settings > Post Processing > Auto Exposure. Then disable all but the Min and Max Brightness and set these to 1. Now you lighting will stay the same. Of coarse if you like or need that feature you are out of luck as far as I can find. Hopefully when Unreal implements the Metal API support this feature will work, here's hoping.

more ▼

answered Nov 10 '15 at 07:20 PM

avatar image

Rankopfpro
1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

@Rankopfpro, thanks for the tips! That seems to have worked :)

more ▼

answered Dec 12 '16 at 07:54 PM

avatar image

blakemcclaren
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question