x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Landscape invisible when not selected + lag

Hey there,

Branch: Binary

Build Version: 4.7.6

System Specs: 8gb Ram - Nvidia Geforce 750 ti - i3 core 3.3 ghz - Windows 7 64 - bit

Repro Steps:

  1. Created Landscpae from r16 heightmap on disk (no problems)

  2. Edited Landscape using "smooth" and "flatten" tools (no problems)

  3. Created and applied a Landscape material using landscape layer blend (no problems)

  4. Painted 5 layers (grass, rock_01, rock_02, sand_01, sand_02) onto the landscape (no problems)

  5. Play in editor (no problems)

  6. Save (no problems)

  7. Right after the save the landscape suddenly became invisible. I thought I might have accidentally unchecked "show landscape" in the viewport options, but that was not the problem. In short, when the landscape is selected, it is visible, and the engine works fine. When the landscape is NOT selected, it becomes invisible and the entire editor begins to lag terribly. However, this only occurs when using "lit" mode. In "unlit", "wireframe", etc, there is no issue with the landscape disappearing if not selected and there are no lags either. I attempted to build the level, but that didn't solve the problem. This problem has occurred before, so I re installed the engine in hopes it would fix itself. It seams that didn't help at all.

Thanks in advance.

dgonik

Product Version: Not Selected
Tags:
more ▼

asked May 02 '15 at 10:57 AM in Bug Reports

avatar image

dgonik
71 4 7 10

avatar image Adam Davis STAFF May 06 '15 at 05:35 PM

Hi dgonik,

I haven't been able to reproduce this on my end using the steps you provided above. Does this occur in a clean project with no additional content or is it limited to one project?

avatar image dgonik May 06 '15 at 10:28 PM

Hello Adam,

This problem has occurred twice so far. In both instances these were completely new projects with no starter content. Additional content was imported only in the second project. In the first the landscape was the only thing I had worked on. The landscape is the same r16 file in both projects, and I have used this landscape before in multiple projects, so I have no idea where this problem came from, since I haven't done anything new.

avatar image Adam Davis STAFF May 07 '15 at 05:22 PM

If you are comfortable with it, can you share the .r16 file? I'll be happy to take a look and see what may be occurring. Additionally, what setup are you using in your material?

avatar image Cosmicabuse Jul 18 '15 at 12:06 PM

Hi,

I'm actually having this exact same issue right now - It just randomly happened (after an auto-save, maybe?), and now I just can't use this map anymore, which sucks pretty hard.

If anyone has an idea on how to debug this, or what file you'd need from me to check this, it'd be GREAT. Thanks!

Edit : a few screenshots to show how it looks.

avatar image Adam Davis STAFF Jul 20 '15 at 05:40 PM

Hi Cosmicabuse,

Does this occur in a clean, blank project with no additional content or is it limited to one project? Is your landscape all in the persistent level or are any parts of it in sublevels? Additionally, did you import this as a heightmap or did you create the landscape in editor?

avatar image Cosmicabuse Jul 20 '15 at 05:52 PM

It occurs on a map, in a project with starter content, and some other stuff I added (Didn't try exporting the map itself into another project, gonna update later if it gets fixed). The landscape is the base of my map, the other stuff being a road on top of it, and some small static meshes here and there. I created it in the editor, and used basic materials with starter content (I think), just to quickly put some snow / grass.

I must add that, this is a huge map - my landscape has this resolution , and is scaled *100 on every axis. The whole scene is a block of around 130k * 120k * 100k.

avatar image Adam Davis STAFF Jul 20 '15 at 05:57 PM

Are you using any culling that could possibly be cutting off landscape sections that are outside of the culling distance?

avatar image Cosmicabuse Jul 20 '15 at 06:04 PM

heh, not really. The only volume I have is a LightmassImportanceVolume. I think I remember messing with culling settings somewhere at some point but, I don't really know where to look :/

EDIT: Exporting the map on another (way different) project breaks too.
EDIT2: Hum, I just noticed the Landscape's Max LODLevel was on -1 (How?), I just put it on 1 and, it works out.

Thing is, I just didn't touch this before, it just... broke. I can't put it back on -1 either apparently.

avatar image Adam Davis STAFF Jul 21 '15 at 02:37 PM

So everything is working now?

avatar image Cosmicabuse Jul 21 '15 at 03:46 PM

Yeah, I'm not having any problem for now. Still weird that the engine just... can't handle this setting. I even wonder what would be the use of setting the Max LODLevel on -1 (Note : it also glitches when set on 0!).

avatar image Adam Davis STAFF Jul 21 '15 at 04:11 PM

Unfortunately I haven't been able to reproduce this on my end. I will leave this open for a few days to see if it occurs again. If so please let me know when it changes and what steps were taken just before the change occurs.

avatar image Tisanim May 11 '18 at 12:29 PM

Same issue here. 4.19.2 Undoing fixes it. But not sure what is being done/undone?!

  • Only some sections of the landscape vanish.

  • Size is small.

  • The Max LODLevel = 1 Doesn't solve it for me.

  • If i delete a section and then add it, it doesn't vanish.

Been doing the heightmap thing but it isn't a solution. :)

(comments are locked)
10|2000 characters needed characters left

6 answers: sort voted first

hello I found a better solution(which is same logic as recreating landscape though this time you don't have to :D) 1-go to landscape 2-manage: 3-change component size: 4-do not change anything 5-apply

more ▼

answered Jul 25 '18 at 06:12 PM

avatar image

Artizan
26 2

avatar image MDancer Sep 16 '18 at 07:19 PM

life saver

avatar image MDancer Sep 16 '18 at 07:46 PM

DISCLAIMER: unfortunately this will remove the foliage from your landscape. use this with care

(comments are locked)
10|2000 characters needed characters left

Think I found a fix

  • Select Landscape Tab

  • Select Manage

  • From drop down list of tools, select "Change Component Size"

  • Click APPLY (I did not change any settings)

  • After landscape is rebuilt it seemed to fix the issue

Before I discovered the above, I tried modifying my landscape material so shaders would be rebuilt; but no luck.

Hope this helps a few people :)

more ▼

answered Sep 29 '18 at 08:36 AM

avatar image

ChiggenWingz
91 1 6 4

avatar image KACPEROGO Feb 08 '19 at 11:33 AM

Thank You, it realy helped me! I lost so much time because of this invisible terrain bug.

I was suspecting sequencer for changing landscape into non-static (in lightmap density mode it was marked brown/mustard colour) - The landscape appeared in one scene animation by accident.

(comments are locked)
10|2000 characters needed characters left

Hi dgonik,

We have not heard from you in several days. I am marking this thread as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.

more ▼

answered May 12 '15 at 03:19 PM

(comments are locked)
10|2000 characters needed characters left

Hi all.

I am currently experiencing a similar issues where my landscape suddenly turned transparent. The other landscape that is clear is copied from another file. If delete the transparent one I will lose all landscape sculpting I have done and foliage populating. Is it a display setting or a hotkey I pressed by accident? The landscapes are fine in other levels but are out of date.

Thank you

more ▼

answered May 01 '18 at 08:53 PM

avatar image

JMAC1295
1

avatar image Alex O ♦♦ STAFF May 08 '18 at 09:13 PM

Hello,

Is this happening in a project that you updated from a previous engine version, or does it happen in a fresh 4.19 project?

avatar image Alex O ♦♦ STAFF May 10 '18 at 12:41 PM

Possible solution: Copy the heightdata with the copy paste tool to another part of the landscape, then delete the corrupt components, add new one in the same position and then paste the heightdata.

(comments are locked)
10|2000 characters needed characters left

Hello, I had a problem where a landscape was invisible unless selected, after upgrading from 4.17 to 4.19.

My solution was to recreate the landscape:

  • Note down the transform for the old landscape (position, scale)

  • Export each layer of the landscape (right click on each layerinfo under Paint, and the heightmap under Sculpt)

  • Delete the landscape and the landscape gizmo actor

  • Create a new landscape (choosing Import from File)

  • Choose the heightmap

  • Re-add the appropriate layerinfos and reimport from file (right click) on each of them

The new landscape works fine for now. (I didn't lose any of my foliage etc)

more ▼

answered May 16 '18 at 10:29 AM

avatar image

Rob McLachlan
39 5 9

(comments are locked)
10|2000 characters needed characters left

i found that deleted the height fog made mine come back

more ▼

answered Dec 11 '18 at 04:10 AM

avatar image

chanceofawesome
1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question