x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why can't UE4 detect Xcode on my Mac?

I have the latest Xcode version installed (5.1), but it seems UE4 can't find it. I can't add any code to the project neither use a code template ("No compiler was found. In order to use a C++ template, you must first install Xcode").

Any idea how to fix this?

Product Version: Not Selected
Tags:
more ▼

asked Mar 31 '14 at 01:05 PM in Installation & Setup

avatar image

cocoapriest
1 2 3 4

avatar image NinaSzeven Feb 07 '17 at 01:20 PM

I'm running into this problem now with El Capitan and Xcode 8.2.1

I've tried renaming Xcode from Xcode.app to Xcode 8.app but It UE 4.13.3 does not seem to be able to find Xcode.

avatar image williamian Dec 04 '17 at 06:01 PM

I am having the same issue but now understand why. I have Xcode installed on a different drive, any way to tell the editor the new current path?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Our check for Xcode presence is very simple - we just check if /Applications/Xcode.app folder exists. Maybe you have Xcode installed somewhere else or renamed?

more ▼

answered Mar 31 '14 at 01:12 PM

avatar image

ZeroEightSix STAFF
2.1k 18 6 36

avatar image cocoapriest Mar 31 '14 at 01:15 PM

aha, got it! Yeah, I renamed this to Xcode 5.1 ( so that I can better track multiple Xcode versions). Thanks!

avatar image silkentrance Apr 25 '15 at 11:40 AM

How about using xcode-select -p to find out the path for the currently selected Xcode instead of hard wiring this to /Applications/Xcode.app?

avatar image Rakesh Malik Sep 05 '15 at 04:44 PM

My xcode was renamed to "Xcode 5.app". Renamed it to "Xcode.app", restarted UE, but didnt work

avatar image Matthew J Sep 10 '15 at 07:25 PM

Hello Rakesh Malik,

Can you provide me with the following information?

  • What operating system are you using?

  • What version of Xcode are you attempting to use?

  • Are you using Unreal Engine 4.9?

  • Did your version of the engine come from the Epic Games Launcher or is it a version you downloaded from GitHub?

avatar image Matthew J Sep 16 '15 at 03:04 PM

Hi Rakesh Malik,

Are you still experiencing these issues? If so, please provide more information in the form of answering my previous questions. In the meantime, I'll be setting this back to resolved for tracking purposes.

Have a nice day!

avatar image Rakesh Malik Jan 01 '17 at 12:11 PM

hi matthew,

details are: OS X El Capitan 10.11.6, XCode 7.0, Unreal Engine 4.14, from Epic Games Launcher

the issue was fixed previously, dont remember how. didnt notice your reply. recently upgraded to 4.14 and got the issue again

avatar image Rakesh Malik Jan 01 '17 at 12:18 PM

issue is only happening in upgraded project. not newly created projects

avatar image Matthew J Jan 03 '17 at 06:38 PM

Thank you for that information. Are you getting the same error that the original poster was getting or are you getting something different? When does the error occur? Is it when you try to open the .xworkspace file in XCode or when you try to open the project itself?

avatar image ColdSteel48 Mar 09 '18 at 11:48 AM
avatar image Rakesh Malik Mar 09 '18 at 12:21 PM

@ColdSteel48 I really don't remember anymore how I fixed it... sorry that I couldn't be of help :(

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question