x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Event Blueprint Update Animation Inconsistent?

Hi,

I have been struggling with animation blueprints for some time now and I seem to be getting inconsistent results inside my event graph that may be the source of the issue.

I have a simple blueprint character, basically copied from third person example project that is using a very simple animation blueprint. It basically just prints the current velocity of the character

alt text

When I hit play in the editor and keep forward pressed on the keyboard I get output showing a velocity of 0 and then ~200 (the max walk speed) switching back and forth between each event firing

alt text

Is this correct behaviour?

If my animation blueprint relies on the velocity to blend the correct animation and is used in transitions how can I rely on this value?

Thanks in advance for any pointers or help

Product Version: Not Selected
Tags:
more ▼

asked May 03 '15 at 01:08 PM in Blueprint Scripting

avatar image

SolarVelocity
596 31 77 51

avatar image Lawsonry Sep 27 '18 at 12:02 AM

I'm running into this as well! 4.20.2. Will post back here if I reach a conclusion.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Anyone figure this out? Running into the same issue in 4.18.3

more ▼

answered Feb 22 '18 at 11:13 PM

avatar image

Jinks67
6 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This happens when animation blueprint is open in IDE. UE thinks there are 2 instances and print velocity for both. BTW, for the instance which is rendered in BP preview you should get None from GetPawnOwner.

more ▼

answered Dec 20 '18 at 08:23 PM

avatar image

Sanchosz
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question