x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

3d widget not hiding (BUG)

3D widget using screen space not hiding?

  1. I am using 4.7.6 version.

  2. I created a new project using 3rd person template. but issue is still there.

  3. I started a new project with 3rd person template > created a widget BP > added an image in middle of it > then created an actorBP > added a static mesh (cube) and the widget i created earlier > placed the "actor" in level > in level blueprint i get the reference of placed actor and set its widget to "enable hidden" on button press H, and set it to "disable hidden" on button press J > play the game, it works fine now > but after setting the widget space to "screen" rather than "world" in actorBP. the issue arrives. it doesnt hide but sticks itself to screen!!

  4. alt text

alt text

Product Version: Not Selected
Tags:
more ▼

asked May 05 '15 at 08:46 AM in Bug Reports

avatar image

VeerChidar
143 30 33 94

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

I was able to reproduce this issue on our end. I have written up a report (UE-14981) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information. After doing a bit of testing I was able to come up with a workaround that may be viable depending on your situation. I hope that this helps.

Workaround:

In this example I have created a custom event that fires off inside of the widget blueprint that is used. In my tests the only method I got to work was setting the Opacity to Zero and disabling the widget. In this example the custom event flipflops between setting is to visible and hidden each time it is called.

alt text

I then used the get all widgets of class to reference all of the widgets of this particular class that are being added to the screen and had them call the custom event that was placed within the widget blueprint.

alt text

Make it a great day

setvishelp1.png (88.1 kB)
setvishelp2.png (145.3 kB)
more ▼

answered May 05 '15 at 02:02 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

avatar image VeerChidar May 05 '15 at 05:33 PM

Thank a lot for the workaround. its working now.. really appreciate it! Cheers :)

avatar image VeerChidar May 06 '15 at 04:51 AM

Hi there again Rudy...

Can you clear something for me? I tried hiding a widget using your workaround. it works fine but in addition its hiding all the other widget out there in level at once. Is this what its suppose to do changing opacity of all widgets?

How can i hide only the widget i overlap ? Thanks!

avatar image Rudy Q ♦♦ STAFF May 06 '15 at 03:24 PM

Sure thing!

I have another example here that will hide a widget on over lap using the same widgets as before. I hope this helps.

Example:

This will simply replace the set of nodes calling get all widgets of class.

alt text

Make it a great day

setvishelp3.png (68.8 kB)
avatar image VeerChidar May 06 '15 at 08:41 PM

Works like a charm!! Thanks again for helping me out...!! :)

(comments are locked)
10|2000 characters needed characters left

Another idea (Set Only Owner See for "Widget Component") Event set replicates to "Run on owning Client"

alt text

more ▼

answered Mar 19 '17 at 07:30 AM

avatar image

Aom Siriwat
6 3 6 7

(comments are locked)
10|2000 characters needed characters left

Hi! There's any update on this? I can see this bug was issued 2 years ago and it's not solved yet. I'm currently in version 4.17 and have basically the same problem.

more ▼

answered Dec 04 '17 at 01:08 PM

avatar image

Dreamseeker5
3 2 6 6

avatar image Rudy Q ♦♦ STAFF Dec 04 '17 at 01:31 PM

Hello Dreamseeker5,

This issue was resolved in 4.8. If you are experiencing a similar issue, I will need you to create a new thread for tracking purposes with more information.

Information needed on new thread:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end

  3. Could you provide screen shots of any settings/blueprints/widgets that may be involved with this issue?

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question