Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Hiding navigation buttons on Android.


Is there a way to access the immersive mode on android from either blueprints or c++? Just to clarify, immersive mode was added in Kitkat(4.4) and is pretty much just hiding the navigation buttons and top panel on android.

Product Version: Not Selected
more ▼

asked May 05 '15 at 12:19 PM in Using UE4

avatar image

61 5 9 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Currently immersive mode isn't supported, but it isn't too hard to add. Supporting it requires an addition to GameActivity.java in Engine/Build/Android/Java/src/com/epicgames/ue4:

     public void onResume()
         // only do this on KitKat and above
         if (android.os.Build.VERSION.SDK_INT >= 19)
             View decorView = getWindow().getDecorView(); 
more ▼

answered May 05 '15 at 03:42 PM

avatar image

Chris Babcock STAFF
1k 11 110 35

avatar image Zimo May 06 '15 at 10:19 AM

Thanks for the help!

avatar image KEALHOVIK Jun 26 '15 at 10:01 AM

In 4.8 GameActivity.java already have this lines, but navigation buttons still on screen.

avatar image Chris Babcock STAFF Jun 26 '15 at 03:03 PM

First, IMMERSIVE_STICKY only works on KitKat and higher. Second, you need to turn on the "Enable Fullscreen Immersive on KitKat and above devices" checkbox in the Android project settings. Lastly, there was a typo in UEDeployAndroid.cs:

             Text.AppendLine(string.Format("\t\t<meta-data android:name=\"com.epicgames.ue4.GameActivity.bShouldHideUI=\" android:value=\"{0}\"/>", EnableFullScreen ? "true" : "false"));

should have been:

             Text.AppendLine(string.Format("\t\t<meta-data android:name=\"com.epicgames.ue4.GameActivity.bShouldHideUI\" android:value=\"{0}\"/>", EnableFullScreen ? "true" : "false"));

The = should be removed.

avatar image KEALHOVIK Jun 28 '15 at 12:00 PM


avatar image ManuCruz Jun 30 '15 at 10:51 AM

I don't find the "Enable Fullscreen Immersive on KitKat and above devices" option. where it is?

avatar image Chris Babcock STAFF Jun 30 '15 at 05:52 PM

I looks like the project setting (in the Android section) was enabled for 4.8. This will be in 4.9, or you can get it from GitHub master branch here:


(comments are locked)
10|2000 characters needed characters left
Viewable by all users

thanks for the help by intertainment

more ▼

answered Mar 10 '19 at 09:13 AM

avatar image

1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question