x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Disabling/Enabling NavLinkProxy

I am using a NavLinkProxy with a smart link to be able to toggle the link on and off. This does not seem to work however. Not even having the nav link set to disabled at start seems to work, the AI still use the nav link proxy between the point where it shouldn't be able to traverse.

Am I doing something wrong ?

Product Version: Not Selected
Tags:
navlinkproxy.png (192.7 kB)
usecase.png (489.3 kB)
more ▼

asked May 05 '15 at 12:21 PM in Bug Reports

avatar image

Robin.UltraUltra
36 2 5 8

avatar image TJ V ♦♦ STAFF May 05 '15 at 03:57 PM

Hi Robin,

I'm investigating your issue and so far I'm getting the same results as you. We are having a meeting with the AI lead tomorrow. I'll bring this up and post back here with an update asap.

avatar image Robin.UltraUltra May 06 '15 at 05:18 AM

That is reassuring to hear, I hope you get to fix this issue in a not to distant version :)

avatar image JaroMast May 14 '16 at 08:30 AM

Still having this issue in version 4.11.

Did you tried fixing it?

avatar image Robin.UltraUltra May 20 '16 at 12:49 PM

My workaround for this in the meantime is to make a wrapper class for the NavLinkProxy which then moves the actual links and updates the navigational octtree when enabling/disabling.

This however might not work depending on you level layout,.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I created JIRA UE-15087 in our tracking software for this. Our developers will be investigating the issue further and we will post back here with updates as we have them.

Cheers,

TJ

more ▼

answered May 06 '15 at 08:04 PM

avatar image

TJ V ♦♦ STAFF
41.2k 1009 181 492

avatar image Robin.UltraUltra May 15 '15 at 12:08 PM

I guess that means you are actively working to solve this issue right now then? (as well as other issues of course)

avatar image TJ V ♦♦ STAFF May 15 '15 at 01:10 PM

It's been logged in our system and the devs will be looking into it. However, like any other issues it's been queued and prioritized. When there is an update to it's status or when it is fixed, we will post back here to let you know.

Please keep in mind that show stoppers and crash bugs always take highest priority.

Cheers,

TJ

avatar image luthage May 17 '16 at 02:01 PM

It's been a year now, what is the status of this bug?

avatar image TJ V ♦♦ STAFF May 17 '16 at 04:49 PM

Hi luthage,

It's currently the same status I reported about. I'll comment in the JIRA to let the developers know that more users are interested in this issue.

avatar image AdamMacDon Jul 05 '16 at 02:43 AM

Any news on this? It would be very helpful for small doorways and other such things.

avatar image TJ V ♦♦ STAFF Jul 12 '16 at 08:10 PM

Hi everyone,

The JIRA entered above was marked as By Design. The reason being is the "Link Enabled" option just basically allows you to toggle between the Simple Link and Smart Link. If there is no Simple Link data, then "Link Enabled" doesn't do anything.

To actually disable the Smart Link, use the "Smart Link Is Relevant" option.

I plan to enter a feature request to make this more clear in the engine.

Thanks,

TJ

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question