x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Physx Lab - "Multi FBX" can't be destroyed

Hello,

I have serious trouble importing destruction meshes from physx lab that were exported with more than 1 Object https://developer.nvidia.com/apex-destruction-physxlab-tutorials#multiple_fbx from Blender. I just can't get them to destroy, but that's not the whole truth...

I have 1 Multi FBX mesh that is destructible! However, no mater what I try, I can't get any other one to work. Also if I fire enough projectiles, they may eventually break up. With some settings and me running around like mad I was also able to achieve some more reliable destruction, however if I don't run around like mad, I can again fire 100 projectiles until one may eventually break up.

It's really driving me crazy, I didn't sleep the whole night, trying every export option of Blender and Physx I could think of, but no chance. All, but the one (my first) Multi FBX just won't destruct as intended from my Projectiles (destruction by player collision has worked for some settings).

Product Version: Not Selected
Tags:
more ▼

asked May 05 '15 at 03:39 PM in Using UE4

avatar image

Cmiller28
20 2 4 6

avatar image Tim Hobson ♦♦ STAFF May 06 '15 at 12:36 PM

Can you open the DM and grab a screenshot of your DM settings and post here? Use the eye in the top right of the details panel and select "Show Only Modified Properties."

Likely there are some values set here that require a lot of damage and multiple hits to destroy the object. Without knowing these settings it's impossible to narrow down exactly what may be going on since you mention that it does destroy on impact with the character and after a lot of hits. Possibly damage cap or damage threshold is higher than you would like.

Let me know.

avatar image Cmiller28 May 06 '15 at 04:12 PM

Hey Tim,

I'm really grateful for your time. This are the current settings of one of the destructible meshes I toyed around. alt text However, I'm afraid this won't give you the necessary Information to track down this Issue. As I've written above, I tried for approximately 8 hours to get this work. I tested various Models (non Multi FBX work flawless), countless Blender export, Phyx Lab and UE4 settings but nothing worked beside the first one which I'm unable to reproduce. It seems like the working Model is the "bugged" one. I also attach a picture of the working model (left), and the model I would like to work (right).alt text At the left one, I had marked the frame to be worldsupport and indestructible. Now one might think, that it might be working because of that, but if so, that would be really bad and make no sense at all. Because at the non working destructible meshes it's like the model has a invisible shield that can't be damaged and deflects all projectiles unless they come from strange angles and penetrate it somehow. That behavior would make a lot more sense to me for the model that is actually working, because it really has a interpenetrate frame around that cannot be surpassed even if everything inside is destroyed.

Maybe it would have more sense, if you send me a screenshot of some blender export settings and a preset file for the Physx Lab with Multi FBX that work for you? But again, I already created 2 cubes in Blender as separate objects, exported, imported to Physx Lab, fractured with default settings and export to UE4 - not destructible. So I really don't know - maybe there's one special miracle setting you need for Multi FBX to work correctly?

hopeless.png (40.4 kB)
hopelessmodel.png (33.1 kB)
avatar image Cmiller28 May 13 '15 at 02:58 PM

Did you have time to look into this yet? If you need any additional Information, like the working model and any of the not working ones I'd gladly provide it.

avatar image Tim Hobson ♦♦ STAFF May 28 '15 at 06:40 PM

Hey, Sorry for the delay. For some reason this one wasn't showing up in my queue and I just found it again. I'll try to look into this tomorrow, but may be early next week before I get a chance. Apologies for the missing this.

avatar image Tim Hobson ♦♦ STAFF Jun 15 '15 at 05:21 PM

Just wanted to update you again. I've still not had the time to look into this, but wanted to make sure you knew I had not forgotten. We've got a lot of work on our team right now with the 4.8 previews and the Full release from last week that we are investigating reported issues with. Right now this is a priority over most issues. I'll update you once I dedicate some time to look into this more. Just not absolutely certain it will be this week or next yet.

avatar image Cmiller28 Jul 22 '15 at 02:02 PM

Hey Tim,

the good news: as of 4.8.2 this issue vanished (I didn't test with 4.8). So I can now destroy every MultiFBX I export!

the bad news: the reason why I wanted the new mesh to function didn't fulfill its purpose. I want to destroy the inner part of the door, and then be able to walk through the door frame. This didn't work with my first Model (left) because the frame has a Convex Collider, there seem to be a backlogged feature request UE-6140 that won't be implemented anytime soon. The problem with my workaround I attempted is that the inner part of the door needs a worldsupport to stick in the frame, but it turns out that the frame has to be static to act as world support and as such can't be rotated anymore - which is bad for something like a door. My next attempt was to use my first Model (where the Frame is a part of the destructible mesh) and disable the collision of it once the inner part is destroyed. But it turns out I can't change the collision of a destructible mesh on runtime.

Do you have any workaround for this?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question